Other SOTA sites: SOTAwatch | SOTA Home | Database | Video | Photos | Shop | Mapping | FAQs | Facebook | Contact SOTA

SMP patching


#1

Due to the never-ending stream of Spectre/Meltdown issues and the overnight exploit that was revealed, I will need to patch the SMP server. While doing this, I’m going to take the opportunity to perform a major version upgrade of the underlying OS as well. I will kick this off shortly to eliminate outages during the major usage times for Europe and NA. I expect this to take about 1 hour, starting around 0400 UTC.


#2

All done. We have normality. Anything you still can’t cope with is therefore your own problem.


#3

and in the process, I’ve broken the backend for newsotadata. Bear with me, there’s a reason it’s in Beta

EDIT: should be fixed now.


#4

Hi Andrew
Since this morning on SMP can’t put any call on Activations mapping page in “Enter activator callsign:”. I’m logged and got “no callsign found” at the start !
73 Eric F5JKK


#5

Yep, there’s a few little bugs I need to iron out. In short, the dump from the main sota database is now being handled more strictly with the latest patching, so I need to un-strictify it.


#6

Hello Andrew,

It looks like the brand new feature of Elevation profiles in the " Range mapping page" of SMP is gone.

Could you please try to reactivate that feature.

Very much appreciated.
73 Joe


#7

It actually hasn’t worked for months and Rob and I had had no complaints so we removed the feature a day or two back as it requires a lot of storage. I imagine the volume the data was on is now toast, so it may take some time to restore


#8

The new version was working fine just two weeks ago.
Thanks for looking into it.

73 Joe


#9

Not sure if this is the place to put it, but the map doesnt seem to be working for me tonight. I went to my association, W4G, and get a window saying there are no records to show. It was working fine earlier today.

Well actually, I noticed that often when you MouseOver one of the mountains on the map, it didnt give you the option to click it, That was a minor inconvenience. Now I see nothing.

Thanks so much for keeping this tool going. It is awesome.

-Steve
W2SWA


#10

Yep, this is my bad. I completely misread an email from Rob and cast aspersions on the operation of SMP. The iotamaps server was hosting the data and that server is moving, requiring us to re-evaluate the usage of the tool


#11

Is there anywhere an online zoomable map showing all the SOTA summits? Just something simple that does not require areas to be selected?


#12

Not “just something simple”, but if you have a fast processor, enough memory and patience, you can try “ALL SOTA summits shown on Google Earth” from http://www.on6zq.be/w/index.php/SOTA/SOTA

When the full list is loaded, do not try to move the globe yet, but deselect “ALL” from the left menu and only re-select the Associations you want to see.

You can of course also select individual Associations .kml files that load much faster.


#13

Perfect thanks. In reality I don’t need “all” but just one or two associations. The SMP interface makes the selection rather tedious.


#14

You’ve inspired me to spend some of my lazy Sunday to try to come up with a world-wide SOTA summit map that shows all the summits at once, and can be zoomed nearly without delay on a reasonably modern computer/browser:

https://neon1.net/sota/summits/map/

It was just quickly cobbled together, so there are currently no filter options and no further features besides getting a detail popup when you click on a summit. But it shows what could be done…

73,

Manuel HB9DQM


#15

Wow! That’s brilliant. Thanks Manuel.


#16

I guess that is just a temporary issue with the summit markers are not showing (but a default one instead)
smp%20marker


#17

As I was checking out a summit on the SOTA Database for the W7A Association, I saw that a track existed. However when I went to the Mapping section for Tracks and entered in the Region, I got a pop-up that said: “Summits-No Records Match Your Request.” I went back and selected some different Regions where I knew for sure there were tracks and got the same message.

Looks like the tracks aren’t loading…

Dave, AE9Q


#18

There appear to be multiple issues with the SMP site now. There’s another thread running here about it. They’re working on it.

I just tried the Range page, and it showed no summits where there are many.

73
George
KX0R


#19

All of these issues were due to a truncated table of points. I’ve reloaded and they should all work.