SOTA Spotter App: Spotting fails frequently

During the last months I frequently fail to send spots with the SOTA Spotter app from Bogdan, YO3SAW. I end up with “Error authorizing with SOTA SSO [1]: status 0” as shown below.

Without changing anything in SOTA Spotter the error comes and goes. Sometimes I can send a spot, but when trying to send a second one half an hour later, it fails. Even when spotting fails, spots of other activatiors are refreshed in SOTA Spotter.
Looking at the session log of Keycloack Account Management ( I cannot see any errors being reported.
I have been in contact with @YO3SAW regarding this problem, but told me he cannot help me as the error is not happening in the app itself.
Unfortunately my tablet used for SOTA activations runs an outdated Android 6. So I am now stuck with version 2.4.557 - the newer versions do not support Android 6 anymore.

Anybody else experiencing this error?
Or even anybody who was able to circumvent this problem?

73 de Michael, DB7MM

Hello Michael @DB7MM.

I also use SOTA Spotter on my smartphone. Android, but with version 11. I know the error you mentioned. However, I only get this with poor mobile phone reception (Edge/2G). I often have to set the same spot until it goes through. Maybe it helps to delete the cache - not the data - of the app. I think you will have to update at some point.

Marcel DM3FAM

1 Like

Marcel beat me to the answer Michael.

The problem was commonplace back in the days of the Rucksack Radio App. Marginal cell phone Internet connectivity caused strange problems causing account login to fail.

The way to prove this is to send the spot as an SMS message rather than over the Internet data link. If your tablet can do that. SMS uses the old base technology and in areas of marginal coverage often works where Internet connectivity doesn’t.

73 Ed.



Often I get a message an SMS has failed (not via the app) whereas it has actually been successful. Again always in areas with poor coverage.


Hi Michael,

I had yesterday the same problem with SOTA Spotter on the OK/PL-004 using my Android 11 phone. One time I was able to send a spot via the Spotter, then every times comes the same error like in your screenshot. This error I saw for the first time yesterday, never happens in the past. But maybe it is connected with bad data coverage, because of rainy and foggy wheather on the summit yesterday.

Pavel OK1MCS

1 Like

I use the app as well. Most of the time if I get an error it’s when connectivity is poor. Often, if I have an analog signal, then the spot goes through just fine via SMS.

I have a different problem with the app though. I can seldom edit or delete my spots even though the capability is clearly there. Sometimes I can though, but normally I can’t.


If people would like to mail or PM me with when they got a an error about access (time date) I will look on the SSO logs to see if it was us or them having a problem. Of the top of my head I think we only have 3 days logs so contact me ASAP when you have a problem or the logs may get recycled.


I don’t think the problem is server-side. It seems that there might be a time out problem in SOTA Spotter in cases where network coverage is poor and responses take longer to arrive. I am investigating this right now.

Thanks to all those who hinted at network coverage as a possible cause for this.

Bogdan YO3SAW


Thanks all for the response.
Looks like I am not the only one experiencing this “Error authorizing with SOTA SSO [1]: status 0” and the problem is not limited to my outdated version of SOTA Spotter.

@DM3FAM Of course at some point in future I will have to scrap the 7" tablet as it does not receive Android updates anymore. But this really hurts, because it is in mint condition, only used for my SOTA activities and there is no up to date replacement on the market.

But I have to clearly state: The error seems not to be caused by poor internet connection. Look at the quite old screenshot from 18.4.22: 4G network with maximum signal strengh indicator.
On 9.9.22 - the last time I got the error, I again had an internet connection fast enough to log in at the SOTAWatch website and send the spot there.

@MM0FMF Thanks for the offer to ask you to check the server logs. I have just dropped you an email “SSO-Logs error with SOTA Spotter” with the details to the hotmail-address - perhaps it is not too late.
By the way: As I want to try out SMS as fallback I have also sent you an email to register my mobile number to the SMS spotting. Thanks @DD5LP for this suggestion.

73 de Michael, DB7MM

1 Like

I like Spotter as a tool but have most trouble reading the screen on my phone out in broad daylight. The grey back ground blends in with the text on the screen to my old eye sight. The other choice of colour is worse for me.
vk5cz …

1 Like

Not just me then. I’ve had numerous issues trying to spot from the app over the last couple of months. As others have already said, the problem seems to be on summits with poor coverage.

If the problem is the mobile network coverage & data isn’t getting through to the servers then I’m not sure if there’s much that anybody can do about that.

I’ve used the SMS function a few times when I’ve needed to but I’m reluctant to use it too often. Although my plan gives me unlimited texts, I’m sure I read somewhere that SOTA incurs a charge every time someone uses it.

Probably too late now as it was more than 3 days ago but I had issues on Kinder Scout on 7th September. Would have been between 9am & 0930am UTC.

Worked ok on SMS.

Same for previous day (6th September) on Shining Tor between approx 1520 & 1550 UTC

I’ll set a higher time out interval for some network requests, which should improve the odds of spots getting through.