Other SOTA sites: SOTAwatch | SOTA Home | Database | Video | Photos | Shop | Mapping | FAQs | Facebook | Contact SOTA

SMP new version goes live!

Morning Rob - tried it before my first cuppa tea - and sorry to say things are still the same. I can only display my own stats at present and no other operators.

73 Phil

I hardly need say that the page needs a good refresh? I can view your chases as well as those of G3TQQ, VK3ARR, N4ADK, XE2AT, F4CTJ, and I gave up after those. It works.

Don’t forget also to reset the time period!

EDIT: you say “stats”? Do you mean the Stats Charts tab in the chases page? - if so, then you have to go back to the first “Mapping” tab in the chases page and enter any new/different callsign there: that’s the only place where a callsign can be entered. The same goes for the activations page.

It probably seems a little odd to do that but, believe me, it’s even odder to have mapping for one callsign and Stats (and Time Charts, Scores) for another. We try to keep order in our little apps!

Well, actually I had no idea of what was on offer in the database until it went live a couple of days ago. But thanks for the flowers anyway!

I think he means the stuff you did with access to the data tables (which you’ve had access to for a a while), not the new sotadata (which I sent the link to you in our part 2 PM thread about posts #128 and #315 :slight_smile: ). You definitely deserve flowers for the data table work.

OK, I forgot about those!

Sorry Rob, still not working for me. I didn’t mean “stats” as such. What is displayed below. I enter activator callsign G3TQQ and I get to see my own activations, not Dave’s if you get my drift. Don’t expect a response from me for some considerable time. I am about to leave for the long drive down to Cardiff.

73 Phil

PS Screenshot:

Thank you Andrew for your patience,
I am glad you discovered what was wrong, but from my side the problem
is still there.
The username GÉRALD has been created by “mistake” in April 2009 and since that day i wish i could change it.
May be you have to sacrifice one or two other Goats…
73 and have good newyear evening.
Gerald F6HBI

Send me a PM with what you want to change it to and I will change it for you.

1 Like

Many thanks Andrew, i own you a bottle of French wine from Bandol.
May be that will help some others that have a username with non standard character.
logded
Gerald F6HBI

1 Like

I like my wines single-malted :wink:

2 Likes

Leave it for now Rob. I’ll check it out on another PC or tablet when I get chance. Journeying now.

73 Phil

It’s working for me when I tried it. I can see my activations and I popped Phil’s call in and his activations were displayed.

There is a bug in the search for activator callsigns as not all are returned. I’ll PM that, it’s not massively important for me as I am found but maybe for others.

Its gone down now, just about to use SMP to plan an activation today :frowning:

Not sure what is not responding but my access to the new database is hanging. I was in conversation with Andrew till just recently but he may have now dropped into the arms of Morpheus. The old DB is up but is about to go down whilst I have a fiddle about in its guts.

EDIT: no SMP is responding to me.

It appears to be a bit hit and miss right now, taking a look at it and seeing what I can do. Lots of requests in train

2pupyg

Well, it was putting substantial load it shouldn’t on the database and causing requests from SMP to be held up and in turn chewing up idle web workers while they waited for the response. Script killed and web server restarted. Holding steady at 10% utilisation of workers. Moral of the story is to not do scripting at 10pm at night on a (semi-)production server.

1 Like

Pathetic level of fail! I once misapplied a DB tweak and gave everyone 3 bonus points for ever activation they had. Suddenly everyone was a mountain goat. Taught me to always have a “WHERE …” condition on SQL that changed anything. Took Gary 3 hrs to unravel the mess as I was still learning just how much damage a SQL command can do.

1 Like

it worked well for me, a humble hunter, after being seen in my Firefox browser, in options and security tabs to find my old logging passwords!
Thank you for this beautiful Christmas gift
Eric F5JKK

Dear Rob,
many thanks for your latest great enhancements of SMP!
I tried to send you the following bug report via the contact page of SMP but I received an error message after pressing “send”.

I found a funny issue on the main mapping page, namely that outdated (invalid) summits are shown.
How to reproduce:

  • Main mapping page
  • Choose Association: DL
  • Choose Region - Multi
  • Select DL/BE --> valid DL/BE summits are shown
  • Select (in addition) DL/MF --> valid DL/MF summits are shown but in addition also invalid DL/BE summits are shown.
  • when I deselect DL/MF the huge number of DL/BE summits is again reduced to the valid ones.

This happens also when I add other regions (e.g. DL/AL, DL/AM, DL/CG) and also when I select “All” regions.
I reproduced it with IE11 (and logged in as dk7mg) but also with Chrome (and without being logged in).
It seems to me that the data base filters are not always set to “valid” summits when a region is added in case of “Multi” or in case of “All” regions".
Thanks,
Andy, DK7MG

And this is the error message that I received when I tried to send my bug report via the contact page of SMP:

Hi Rob
Forget my issue. Selecting callsigns other than my own in the chaser or activator mapping page on a tablet and phone works as it should. I’ll investigate the PC concerned when I return home, confirmed it is a local issue.

73 Phil