Other SOTA sites: SOTAwatch | SOTA Home | Database | Summits | Video | Photos | Shop | Mapping | FAQs | Facebook | Contact SOTA

OE/DK3IT/P on OE/TL-024 strange keying

Hi all
I think was the first on CQ call of Martin 7.002 at 13:04
Noticied nice signal 599 on his CQ :+1:
But in his response on my call got strange CW like AFSK!
I had 44 years on CW professionaly and Ham radio and I decode his response but was hard for other callers.
After when he moved on 7.029.9 30 minutes after the keying was ok ?
Here you can listening his strange sigs :

I think when Martin was sending CW memories was OK
73 Eric F5JKK

Sorry can put a Dropbox link … I think not allowed or reading a .m4a file :frowning:
Martin will send you a recording of what was hearing
73 Eric F5JKK

Now on OE/TI-478 you had 599 clean keying :wink:
73 Eric F5JKK

Dear Eric,
thanks for this thread! Short story is: Never take gear to the mountain that you did not test down in the valley :wink: I updated the firmware of my MTR-5B-based GoBox station last week and did a few quick tests at home. Either uploading the firmware did not work correctly or the binary version 1.9 does not fit my hardware.

I tried for almost an hour to complete the activation, but almost nobody came back with a report for me. Initially, I thought that this was due to the very bad CONDX. But then I looked into Sotawatch and saw that @PA9CW (Tonnie) had posted a spot saying “Calling cq. But coming back with strangs dots and dashes.”.

Luckily, I had packed my TinySOTA (MTR-3B) as a backup and then changed rigs. This is why the problem was fixed after 13:38 UTC.

That was a close match - this was a 3-summit winter activation, and being left with a faulty rig on the first summit 4 days before the Winter bonus ends would have been quite a disappointment.

Will post an activation report shortly.

73 and again mni tnx!
Martin, DK3IT

2 Likes

Martin,

thanks that I could help you. I called you on 7002. But when I heard you coming back, it was just if the dots and dashes were changed. So a dot was a dash and a dash was a dot. Could not mak any sense of it.

On 7029 I worked you finally. Always good to have a backup :slight_smile: Thanks for the points and GL.

73 Tonnie de PA9CW.

Hi all:

I investigated the issue at my bench - it must be some software problem with the firmware update, because

  1. sending from the memory keyer works fine (sidetone and output signal)
  2. sending from the paddle sounds fine from the sidetone, but the output signal is almost incomprehensible - dots and dashes are slurred together, as if there was a slow ramp up and decay instead of sharp differences in amplitude.
  3. in the single keyer mode (pressing dah during power-on), the keying works fine, so it can’t be a hardware problem.

My suspicion is that the power limiting function for the TUNE mode (a simple PWM so that the average voltage is lower than the supply voltage in tuning mode) is active for some strange reason and interferes with the dot and dash generator routines.

73 de Martin

Martin,

can’t you downgrade the firmware back to the original firmware ?

Good luck.

Or discuss with LNR about the case. I would expect that they are interested to hear about it too.

If you have equipment to do so: Maybe record a bit of I/Q stream with an SDR so that they can analyze it.

73 Joe

Hi all,
Thanks for your suggestions! I just posted a message to the Yahoo ATS forum; Steve Weber often replies very quickly to requests in that forum. Will relay my findings.

73 de Martin, DK3IT

Steve got back to me and said that the 1.9 version is buggy and should not be used. The recommended version is 1.11; unfortunately, I do not yet have a binary for that release, but am trying to get hold of it.

73 de Martin, DK3IT

In the meantime, I received version 1.11 of the MTR5B and 4B firmware from Steve Weber. Unfortunately, I does not solve the problem.

It is a pity that I forgot to back up the old 1.8 firmware that was loaded by LNR.
If anybody has an MTR-5B from LNR and is able to create (or has created) and share a binary file of the firmware, that would be great.

That is actually easy and for sure a good safety measure anyway. Either run

msp430_read.bat

from the MTR V2 REV 2_06 burn files.zip package or enter

mspfet +r -o msp430.bin -FET=TIUSB

So if there is a file msp430.bin on your machine and if you own an MTR5B from LNR, that would be really nice to have.

73 de Martin, DK3IT


EDIT:
Hi everybody,
with the great support given by Steve Weber, I found and fixed the source of the problem: In fact, it was no software issue but a hardware problem that had been in my rig ever since I bought the MTR-5B from LNR:

The PCB contains TWO capacitors labelled C76, one near the LCD and one near the PA transistors. The numbering on the schematic in the MTR5B manual is different, by the way.

One of the capacitors is 1uF (thicker, darker brown color) and one is thinner and light brown in color. Correct would be the 1uF at the LCD and the 0.01 uF in the PA stage. Unfortunately, the factory misplaced them both in some production batches, which slurs the keying envelope. Once I swapped the two capacitors, the problem is gone.

I still do not understand why the signal from the memory keyer was much clearer without the fix than the signal from the paddle; maybe the timing is a little bit different. I also do not understand why I have had successful activations with the rig prior to the fix; likely, my chasers had very good ears. Or the problem got worse over time with my aging NiMH cells that might have added additional loss of steepness of the keying envelope.

Anyway, this seems to have been the true issue, and since I never checked my own signal live on the air before (and stupidly relied just on the side-tone), it went undetected for more than a year.

73 de Martin, DK3IT

1 Like