Other SOTA sites: SOTAwatch | SOTA Home | Database | Summits | Video | Photos | Shop | Mapping | FAQs | Facebook | Contact SOTA

I can't upload tracks

Hello,
There is a problem, this is the track, does not show error
Thank you, 73

In Firefox it works fine, in Chrome it doesn’t
73

Nope, it’s not a browser issue. At some point it appears that SMP decides to clear out its temporary files and the file you upload vanishes. I have seen this when people edit GPX files prior to uploading, which suggests a race condition between the file deletion and the passing of the file to the backend to process.

I have observed this issue in the past. Thanks for the analysis.
Another one:
And if one edits the track and then changes the map-type (from google to opentopo for example) everything is reset to start.

Certainly. I have edited the original track leaving only the climbing up and erasing the entire descent, because was done by another longer and more difficult route. The complete track..
From now I will use FireFox to upload edited tracks…
Thanks

Hi Andrew. Same here with Chrome, 2 weeks ago I tried to upload the JA/HG-021 with Chrome and it was impossible and I didnt touch the GPX files. In the other hand I could upload it using Microsoft Edge browser.

I confirm, not saved with Chrome, and works fine with Firefox (installed on purpose)!
73 Gerald F6HBI

I just tried with Chrome and it works fine. I’m still reasonably certain it’s some kind of race condition - something is clearing out the temporary file before it can be processed. I suspect that Firefox will fail occasionally too.

I’ll try trace down the bug but these things are notoriously difficult to find.

Hi Andrew, I have tried Chrome and it doesn’t work in my browser. Don’t worry it works fine in Mozilla.
TNX & 73

In a different thread, I had reported an inability to upload tracks. I was using Chrome. After reading the latest posts to this thread, I tried MS Edge and was successful in uploading tracks for K0M/NE-021. Not sure if that will help t-shoot the underlying issue with Chrome, but hope it helps others get their tracks uploaded successfully by changing the browser used.

73 Paula k9ir

Quick update - just tried to upload another set of tracks using Edge. Got as far as the tracks displaying on the map, and the elevation dialog box popping up. But when I clicked “Import,” nothing happened. tried again in Chrome with same result.

This was a set of tracks that didn’t cause the message about too many points, so I thought I would have a clean upload ;-). I did bring the data over from my Garmin into Basecamp, cleaned up my tracks and saved as a .GPX file, which I then was able to upload, but not save to the database.

73 Paula k9ir

Send the gpx file to admin @ sotamaps.org please

Also, could folks having problems share the output of chrome://extensions/ with the admin @ sotamaps.org email address too

From Gerald F6HBI
since this morning i can upload track as before (with Chrome).
Gerald

I pushed a small change yesterday to stop a feature that may have been triggering a login/logout in the background, and/or running into security policies on new browsers - however this should have impacted any recent browser, whether FF, Chrome or Edge, which doesn’t tally with most people experiencing it on Chrome and not on FF - unless you have an old version of FF installed.

1 Like

Hi,
I have the same problem now, can not upload my track.

I tried to upload with FF and Firefox-ESR on Linux, and with FF, Chrome and Edge on Windows10 (all browsers latest release). Always the same result. Should I use some older version FF ?
Any suggestions? Is it just my problem or general issue?

73,
Mirko, S52CU

Can you open the web console using F12 and clicking on “console” and tell me if there are any logs there after you click?

I assume you are not using any privacy plugins?

Hi Andrew,
Thanks for promp help,
yes there is a message:

This page uses the non standard property “zoom”. Consider using calc() in the relevant property values, or using “transform” along with “transform-origin: 0 0”. tracks

Nalaganje/loading/za z virom “https://www.sotamaps.org/js/jquery_fancy_tree/dist/jquery.fancytree-all.min.js” ni uspelo /was not successful/ . tracks:1844:1

Nalaganje za z virom “https://www.sotamaps.org/js/togeojson/togeojson.js” ni uspelo. tracks:1845:1

[KEYCLOAK] Usage of legacy style promise methods such as .error() and .success() has been deprecated and support will be removed in future versions. Use standard style promise methods such as .then() and .catch()` instead. keycloak.js:73:21

ajaxfileupload:last50chars: :"",“type”:“End”,“number”:2,“wayPtID”:“waypt_1”}]} tracks.min.js:305:463

Uncaught TypeError: aImportedGPXData.trackPoints is undefined

showSaveGPXTrackOptionsWin https://www.sotamaps.org/js/tracks.min.js:241

onclick https://www.sotamaps.org/tracks:1

There’s a problem in here, but I’ll have to dig deeper to see if there’s any errors on the server side. How big is the GPX file?

File is 72.7 kB, and there are 1144 uploaded points.
I can send a file in pm if needed.
73, Mirko