Other SOTA sites: SOTAwatch | SOTA Home | Database | Video | Photos | Shop | Mapping | FAQs | Facebook | Contact SOTA

Exporting problems


#1

Hi all
I have never saved my chaser log to file using the button on the database. I decided today that it would be a good idea for various reasons. However I am having a problem and hopefully someone will have an idea.
I don’t use MSOffice I use the rather wonderful, and very free, OpenOffice. The database saves the file as an excel/spreadsheet which is useable with Openoffice. The file appears to be saved as a .xls but in fact is saving it as .txt. I’ve tried a few things but I can’t get it to open as a spreadsheet.
Has anyone else had the same problem? Any suggestions?
Cheers
Q GW3BV


#2

In reply to GW3BV:

Which OS are you using (Windows, Linux, Mac)?


#3

In reply to GW8OGI:

and which browser ? (Firefox IE6, IE7)


#4

In reply to GW3BV:

Hi Quentin. The file is a text file (csv format). I am having no problems opening it in Open Office.

Can you please be a bit more explicit. How are you trying to open the file? Are you double clicking in an explorer window or using file/open in OO? You say it won’t open, but what is the error message?

More information needed.

73 John GW4BVE


#5

In reply to GW3BV:
Hi Quentin
As John has said the file is .CSV (comma separated variable’.
You need to browse to the file.
Right click
choose ‘open with’ and scroll (or browse) to scalc.
A dialogue will come up - make sure ‘comma’ is selected.
OK

Roger G4OWG


#6

In reply to GW8OGI:

Just fired up a Windows machine (I don’t use it myself) and IE 6.

Clicking the Save to File button on the My Activator Log page, Internet Explorer asks me what to do with the file. If I click on Save, it opens a dialogue box asking me where to save the file. The filename is GW8OGI_log_20071214.csv indicating a csv (comma separated values) file rather than an xls file.

If you have “Hide extensions for known file types” selected in Explorer, the .csv on the end of the filename will be hidden, however it is still a csv file.

I have just discovered that csv files are not opened by Open Office by just double-clicking on them unless you selected that option during installation.

So one way to open them is to go into Open Office first and then telling it to open the file from there.

To fix this permanently, right-click on the csv file in Explorer, select Open With, scroll down until you find scalc (which is the Oo spreadsheet program). Select this by clicking on it once. If you tick the box that says “Always use this program to open these files” then whenever you double-slcik on a csv file it will open in the Open Office spreadsheet program. Click OK and that should be it.

73

Ian.

(At you own risk, not my fault, blah blah blah)


#7

Thanks everyone and apologies if I didn’t provide enough information first time.
I am using XP and as a browser I use Opera. It seems that the problem is with Opera and Open Office. I tried using IE and when I went to save file the extension was .csv and I was then able to open it in OO. However if I save it in Opera it saves it as a .xls which OO opens, for reasons best known to itself, as a Text document. No matter what I do to it then it will not open it as a spreadsheet.
Confusing. At least to me. Anyone got any experience with Opera?
By the way why is the reflector saying that this post was started by Ian?
Cheers
Q GW3BV


#8

In reply to GW3BV:
I have XP on this machine and both Opera 9.21 and Firefox 2.0.0.11.

With Firefox the file is saved as a standard CSV file (comma separated values) with a .CSV extension. Opera saves the file with a .XLS extension but the file is actually a CSV format file not XLS format.

I don’t know if this is Opera being clever and can be disabled or if it is something the website/database code does. But you could try setting Opera’s user agent string so it says it’s Firefox and see if it saves it as a .CSV.

Andy
MM0FMF


#9

If I download my log in Opera it wants to save the file as .XLS too, where-as Firefox and IE 6 seem to default to .CSV.

My Opera also shows a mime-type definition for the file of application/vnd.ms-excel which may be coming from the web server (I couldn’t determine if that was coming from the server or Opera making its own assumption).

However RFC4180 (http://www.faqs.org/rfcs/rfc4180.html) defines the mime-type for CSV files as text/csv.


Stewart G0LGS


#10

With Firefox the file is saved as a standard CSV file (comma separated
values) with a .CSV extension. Opera saves the file with a .XLS
extension but the file is actually a CSV format file not XLS format.

Andy
MM0FMF

So if Opera has only changed the filename extension and not the file format you should just be able to rename the file and open it in OO

73 John GW4BVE


#11

Groan.
A lot of this is going over my head, however…
If you try to change the mime type thingy to .csv the result is the same. OO opens it as a text file. However if you change the program to open the file with to scalc, and then click save on the Opera pop up, and then in the XP pop up add .csv to the end of the filename and save it, it will then open it as a spreadsheet in OO. I think.
All seems a bit long winded to me. However it is possible and therefore I am happyish.
Q


#12

In reply to GW3BV:

Hi Quentin

Just right click on the file in Windows Explorer and rename it with a .csv extension instead of an .xls extension. Job done.
Or download the file using a different browser.

73 John GW4BVE


#13

In reply to GW4BVE:
Hi John.
The easiest option seems to be to use IE!
By the way have you given up 5megs as an activator? 80mts is not great for me and 40mts is going over my head to the continent! I have missed you on 5 megs :wink:
Cheers
Q


#14

In reply to GW3BV:

The easiest option seems to be to use IE!

No, no and thrice no. Never use IE. It’s not rocket science to right click the downloaded file and change it to .csv. Or install Firefox. But don’t use IE.

Andy
MM0FMF