Other SOTA sites: SOTAwatch | SOTA Home | Database | Summits | Video | Photos | Shop | Mapping | Sotlas | FAQs | Facebook | Contact SOTA

Zippy 4200mah battery - have I killed it ?

I used the Zippy 4200mah battery for two activation’s over the weekend and worked fine.
Left the battery connected to the radio when I packed away.
Got the battery out to charge today and connected to the Turnigy charger.
Set to LiFe Balance charge, 1.3a 13.2v (4S), pressed start and got an error.
“Cell error Voltage invalid”

Checked voltage with a multimeter and got 5.5v? Also tried with a plug volt meter display that connects via the white multi-pin and that didn’t show any voltage.

Is it bust?

1 Like

Hi John @M0VAZ ,

What is the voltage of your Zippy? And what cell is it, 3…or 4 etc etc?

5.5v measured across the main power connector.
Its a 4S2P 13.2v.
It does feel slightly puffy compared to the other one.

2 Likes

Hmmmmm, yes that doesn’t sound good. You could try setting your charger to 14.4v and dropping the charge current to 1.0a. But stay with it for a few minutes if it does decide to charge.

I fear so. If the voltages per cell falls below 3V, the battery will be damaged. A lipo pack should always be equipped with a protection circuit that interrupts the current draw in this case. Even if your transveiver was switched off, it draws power from the battery. With the known FT-817, this is a few mA and the worst case occurs in hours with a discharged Lipo.

73 Chris

1 Like

1.4V per cell :open_mouth: :frowning_with_open_mouth:

1 Like

Sorry 6.4v, but that doesn’t make it any better. :frowning:

1 Like

Normally I unplug but this time I forgot. :frowning:

1 Like

I have sent hobby king an email…Lets see what they have to say.

I did the same thing to a 3S LiPO John and it never recovered. Unfortunately it doesn’t look good for your LiFePO4. I note you are trying a balanced charge. I wonder if your charger has other settings to try - if so the storage setting might get it started, but as to whether any life can be breathed into it is another matter. :hushed:

1 Like

It doesn’t look good.
I have;
LiFe Balance Charge
LiFe Charge
LiFe Fast Charge
LiFe Storage
LiFe Discharge

Yea I think its dead. Lets see what Hobby King come back with. If not, its time to buy another one as a spare.

1 Like

Good luck getting a replacement. £40 to buy, another £40 to ship!

Yea cheers. Just see the £35.94 to ship.(for 1) but for 4 batteries is £53…Group order?

1 Like

It’s an obvious idea John. Just remember shipping in the UK will be an issue so best if you go ahead to arrange a face to face meeting to hand over the goods.

Meeting up/delivery would be an issue. Forum relay might work…

Almost certainly :frowning:

Minimum in-service discharge voltage for an LiFePO4 cell is 2.5v and irreparable damage starts at 2v so I don’t hold out too much hope for your battery. If left for a time the voltage will sometimes recover a bit which may allow the charger to work but if you do manage to get it charging you need to watch it very closely for swelling and heating. If you do get some charge into it you may well find the capacity is seriously reduced.

If it was my battery I wouldn’t be able to trust it and would dispose of it safely (please NOT by putting it in a bucket of salty water :rofl: )

73 Paul G4MD

My charger has a “repair” option on it which I think restores over discharged cells to some extent, although I haven’t used it.
If it’s puffed up though it sounds like the damage is terminal.

Yea I think the damage is terminal… :frowning:
Mental note, next time disconnect the battery when not in use.

You have my sincere condolences for your loss John

1 Like

Thanks. RIP young battery of 4200mah capacity. Time to arrange disposal. :frowning:

1 Like