Xiegu X6100 - Strong RX signals trigger TX - Solved


I own a Xiegu X6100 and I have noticed the following behaviour: The transmition of the RIG is triggered when a strong signal is received (I always do CW).

My observations:

  1. When a strong signal is received, the rig moves to TX intermitently (and therefore I can’t receive the station that is calling).
  2. Adding the attenuator helps, since in general it fixes the problem (but if the signal is extremely strong, it still persists).
  3. If I decrease the audio volume (I work with headphones, though!), the problem seems to disappear.

Has anyone had any similar experience? Am I missing any setting (let’s say that the instructions manual lacks some explanations)? Any idea of what can be happening?

Thanks in advance.

73 de Ramon, EA3AVV


I do not know this rig, but what you describe sounds like a serious fault. I wonder if there is a bi-directional RX-TX stage that can provide enough power from the recieved signal to trigger the TX into life.


I don’t know the X6100 either…

Has it always been like this? -
If so: warranty case
If not: what has changed?

Can this be related to the VOX function?

I remember having a TRX where the CW function was paired with the VOX function which was… but I don’t remember which one…have you already checked these settings?

73 Armin


Hi Armin, Hi Ramon,
I also don’t have an X6100, rather a G90, X108 and G106 from Xiegu.
I think you have probably pointed Ramon in the correct direction armin, VOX and CW-Breakin settings are often related in some transcievers, however I think Ramon, you would be better contacting the shop where you bought the radio and see if they can help.

If you bought it through Radioddity, I have found their support team to be very good. Worst case, as long as the radio is still under warranty and you are the first owner and bought from them they can replace the complete radio if they feel it is an actual fault. I had a faulty button on the Xiegi G90 that I bought from them and they replaced the complete radio.

I presume you have done a “reset to factory settings”? With so much of modern radios being computer based, (the X6100 is a linux computer with RF boards) this is the best first action. Often whatever the corruption of CMOS or wrong parameter setting was, the reset restores normal operation.

If you bought the radio second-hand you have less options but you could join
xiegu-x6100@groups.io | Home
That is one place where X6100 owners meet.

73 Ed.

1 Like

I have a G106 and that gets swamped with AM/MW broadcast, making any incoming signals difficult and sound like they are massively powered… I got a BCI filter from www.Radio-stuff.com and this seems to have helped massively with the incoming signals strength, and clarity, as well as removing the AM/MW ghosting…

I did a little video just to demonstrate the BCI last weekend…

Alan Hamradio UK - Adventures on the air! : New portable setup, Xeigu G106 ironing out the problems... 01/09/23

Cheers - Alan

1 Like

Hi Ramon,
I had a similar experience on a summit but on another brand of small rig. I found I had the vox on and the antivox needed adjustment. Turning the vox off fixed the problem.


1 Like

Make sure VOX is on.

I suspect that the built in mic is engaged.
Try to set:
Radio setting 1
Mic Sel: HAND (Not Auto nor Built in)

Tell us if this cures the issue.
Fingers crossed…

73 Ignacio


Hi everyone,

First of all, thank you very much for your responses, it is very pleasant to see how quick the community reacts to solve anyone’s problems!

Roger (@EA3M) and I have been looking into it based on your comments, and we believe we have found the issue. I explain it below in case it can be of any help to anyone in the future:

First of all, we tried to reproduce the problem with my son. He lives approximately 1 km away from my QTH, so first of all we have made sure that the TX of the X6100 triggered when he transmitted in CW.

And then, we realized about the following: the TX was not triggering without headphones! Similarly, the TX was not triggering when any other headphones were plugged, so it had to be something related to the headphones I am using in my activations, not to the RIG.

We had a closer look into the headphones and indeed, there was something special about them that we hadn’t realized: the connector has 4 pins instead of 3 (there is some sort of button in the cable, a microphone, I presume). This has never been an issue neither from the RIG I use in my fix station, neither with an Elecraft KX2 I sometimes use, so I never paied attention to that. But apparently it creates problems to a Xiegu X6100. Good to know!

In any case, problem solved. Thank you again for your quick replies!

73 de Ramon EA3AVV


Mui bien. Felicitaciones.

1 Like

Hi Ramon,
glad that you found the root cause!

Enjoy your next activation without audio cut!

1 Like

All my headphones with 4 pin have a microphone, so they are headsets. Therefore, it may be that the connection with a VOX are.

73, Peter - HB9PJT

Hi Ramon,
Well done on finding the cause!
The 4 connector 3.5mm plug is the one needed for smartphones which indeed includes stereo listening and a microphone in the standard (along with the ability to “ptt” to answer a phone call/mute/unmute audio and to be able to change the audio level via a small switch/slider in the earphone cable (this switch/slider unit normally also contains the microphone)).
More important than the extra ring however is the fact that the connections are wired differently and the sleeve connection is not earth!
This diagram shows the differences and how to use “normal” headphones and microphone with a smartphone/laptop.
You basically want the reverse - you want to go from the 4-connector plug on your headset to the 3-connector 3.5mm plug.
It’s probably easier to use a different set of headphones as you have tried which already have a three connector plug.
Here’s the speaker/headphone output socket specification from the X6100 Manual:
Although it shows two audio connections, I expect this is Mono out (i.e. both channels are the same) not stereo. DO NOT be tempted to use a mono 3.5mm (2 connector) plug however as that may cause damage.

Interestingly to save space the X6100 uses the 4 connector 3.5mm plug for its ACC port (where normally a mini-DIN plug would be used) but wired in a special fashion as shown in the manual.

73 Ed.


Great result well done.

1 Like

Hi Ed,
Thank you very much for your explanation about the 3 and 4-connectors. Really interesting and good to know!
73 Ramon

1 Like