Other SOTA sites: SOTAwatch | SOTA Home | Database | Summits | Video | Photos | Shop | Mapping | FAQs | Facebook | Contact SOTA

Unable to post SOTA alert on SOTAWatch3

I was unable to post SOTA alert today 10/24/2020 for St. Helena Mtn (SOTA W6/NC-030) at 23:00 UTC 14.063-cw, 10.113-cw, 7.033-cw? It did not accept a valid summit code. Copy of screen shot is attached. Did anybody else experienced such challenges? What may cause it - Microsoft Edge browser or something else is not work properly with SOTAWatch3? Can anybody else help me to post this alert? I am going to make this SOTA activation attempt right now.

73! Oleh
KD7WPJ

Hi Oleh, @KD7WPJ
Just posted your alert :wink: I had to click on second reference …
73 Éric

2 Likes

I get that error message often. I just re-enter it and that seems to work.

Malen
VE6VID

2 Likes

Worked for me with Firefox

Thank you, Eric!
I was lucky having cellular signal on the summit, and I was able to self-spot myself, but your alert helped to get more chasers!

73! Oleh

1 Like

Still have the same issue. I made attempt to post alert for W6/SC-153 using Microsoft Edge and Google Chrome web-browsers, and was unable to post alert, because of message "Valid summit code is required (XX-XXX).I am wandering if this issue is related to W6/SC-XXX database only? Maybe SOTA watch does not interpret correctly SC-XXX? Or maybe this summits group wildcard is missing for any reason? Or maybe SOTAWatch3 does not have access to this database/ARM? Copy of screen shot is attached.

Oleh, I’m now logged in as you and I can alert for that summit. This must be something local to your PC/software.

So, I have seen this before, but never in a place where I could get into debugging it. It only happens when you select the summit from the dropdown, and can be easily resolved by deleting the last character of the summit reference and reentering it manually.

Essentially there’s a function that takes the summit reference from the dropdown and stuffs it into the reference field, with my guess being that the issue is there’s an additional character or something that’s triggering the regular expression check on the reference text box.

I made another attempt, and was able to reproduce it by doing nest steps:

  1. Login into SOTAwatch3.
  2. Entered Callsingn “KD7WPJ”.
  3. Entered Association “W6”.
  4. Entered the first letter of Summit Code “S” and got message “Valid summit code is required (XX-YYY)”. I can see all summits from the drop down menu for “CD” summit after I entered “N”, but I am unable to select any of them, because of popped up message. When I entered “SC” - then summits from the drop down menu changed to “CT”. I also try “N” and “NC”, and summits from the dropdown menu are “CD”, but for “NC” - summits are from different groups “WH”, “CC”, “IN”, “NE”, and they are out of order.
    What can be wrong with my software? Do I need to reinstall Windows 10?

Using Safari.
On step 4 typing “NC” I get the red warning.

finishing NC-030 the red warning disappears.


If I click NC-030 from pulldown menu it becomes red again.
If I continue without clicking the pulldown I am able to finish the alert.

73, Hans PB2T

My problem is intermittent which makes it more difficult to understand and to investigate. Yesterday I was able to post alert for W6/CT-150 without any problems. But I got error message “Valid summit code is required (XX-YYY)” immediately after I entered ‘W6’ association during an attempt to post alert to the second summit. How SOTAWatch3 can determine that summit code is invalid if I did not enter any summit code at all? MM0FMF logged in as me and was able to post alert, but I was not able. This may indicate that latency was involved. In other worlds - how much time it took for my computer, the internet, and everything in between, to respond to an action I took. Maybe delay is outside of SOTAWatch3 expectation? Which IP address I should ping to measure delay?

I think most likely is exactly which keys, mouse clicks you make. If I follow Hans steps I can enter the association and summit and have the red box displayed still.

If I click in a field and enter the data, then use the mouse to select the next field and key in the data and keep using the mouse to click in the subsequent boxes and enter the data then everything is perfect. If I use the TAB Shift-TAB key press to move between boxes then it is possible to get the red warning left behind.

If you enter partial summit details by key then select a summit from the dropdown the warning disappears. If you fully enter a summit ref by key, the warning disappears and a single summit is shown in the dropdown and if you click that summit name, the warning reappears. So don’t click the name if you have entered all the reference. Just click the next field you wish to enter.

I tested clicking in the association field and entering W6 and I waited 5+mins, no other boxes were auto-filled.

Population of drop-down is including a trailing character? Or error detection fails to trim trailing spaces before validating?

Another possible suspect is that the html5 pattern matching that verifies the summit is not called, or is called before the typeahead has updated the input box, so it’s a good old fashioned race condition.

1 Like

I’ve narrowed it down to a specific condition, which appears to be:

  • it only appears when you’ve typed the whole summit code (eg, VC-022) and then click on the typeahead dropdown.
  • This seems (without me being able to see too deep into the JS engine) to set the field to be VC-022, which is valid, then to “VC-022 - SummitName” (due to the typeahead), which marks it invalid, then back to “VC-022” due to the output formatter on the typeahead.
  • I suspect the issue here is that the summit is not rechecked for validity after this and so the “Invalid” result is the one that stays behind.

Andrew,
I have been getting red warning codes not just for summits but for frequencies as well, but I ignore them and keep typing until all is entered. No red screen warnings then unless I have stuffed up.

73
Ron
VK3AFW

1 Like

Hi Ron,

There’s no checking frequencies when posting alerts.

Cheers,
Andrew

And yet the red panel appears.
R

Are you talking about spots?

I’ve had the same issue Oleh reported several times in the past week now. I don’t click on the drop-down menu items. I simply enter the entire summit ref and then get the “red box” saying “valid summit code is required”. In fact, I only see maybe the first 10 or so summit refs so I can’t “click” on the summit I want as it’s not listed.

I was able to make this work by completely closing Sotawatch3 and then go back in to create my alert. It then worked just fine. I’ve never seen this issue when posting alerts via SOTLAS. BTW, I use Firefox as my browser.

73, Brad
WA6MM