Other SOTA sites: SOTAwatch | SOTA Home | Database | Video | Photos | Shop | Mapping | FAQs | Facebook | Contact SOTA

Summit Icon

Hi,

I have realized that if I change the summit Icon from “Peak Symbols” to “Activation Counts Circles” and I try to click on the icon to get the summit information pop-up then nothing shows-up (it works with Peak Symbols"). If I try to double-click on it then the following message appears: “ReferenceError: enableZoomOnFuzzyBorderDblClick is not defined”

This is on Win10, Version 58.0.3029.110 (64-bit) of Chrome.

Thanks!

73,
Arnaud
JG1XMV / KD2AFE

Hi Arnaud,
It works here (albeit with Firefox rather than Chrome).

Have you tried refreshing your browser after making the change? (ctrl + F5 in Firefox - not sure in Chrome - it might be the same).

73 Ed.

Hi Ed,

Thanks for having a look. I have played around with it to see if I could dig further into the problem following your post. Please see my settings below.


What I have found is that some summits work fine when you click on them while others do not.
For example these 2 summits that are next to each other:
F/AM-193: This is ok.
F/AM-156: This one does not work.

One thing I have noticed is that when I hover above F/AM-156, it indicates F/AB Alpes Mont Blanc as nearby SOTA region while F/AM-193 does not. So I am wondering if there is something in the GUI that makes it confused with regards as to whether it is a F/AM or F/AB summit. Maybe I am wrong but just something I noticed.

If you need me to test anything else on my side, feel free to ask.

Thanks,
Arnaud

I’m sure Rob, DM1CM, who is the programmer, provider and all-round Guru of SOTA Mapping will see this thread and respond soon.

The SOTA mapping tool has so many different features that while we could guess at what the problem from your side might be Arnaud, it’s definitely better to await Rob’s input.

73 Ed.

Understood Ed, thanks.
Out of curiosity, did you manage to replicate this on your side with my settings for F/AM-156?

73,
Arnaud

All the ones I hover over come up with their name - I haven’t been able to find the actual ones you refer to yet, however I wonder what Layers you have turned on - I find having neighbouring regions shown to be confusing and turn it off in Layers - perhaps that’s why I don’t get the problem you report?

Hi Arnaud, Ed,

I think we have three problems here, one of which - as Ed has pointed out - is easily remedied by doing a browser refresh in the page: F5 to do a “shallow” refresh, or Ctrl+F5 to do a “deep” refresh.

The other problems have to do with how Google maps handles overlays which are superimposed on each other. Overlays are like transparent foils which can display objects, rectangles, markers, etc.; these overlays are placed in various map panes, like the stacked panes of glass in double- or triple-glazed windows, each of which occupies a definite level in “z-space”, or vertical stacking.

The problem comes when there are many such stacked foils or panes, each showing different and overlapping objects: when the mouse hovers over objects occupying the same x-y position, but different vertical (z) stacking position, and if these objects have defined mouse-events (i.e. show a small info-box on mouse-hover), then google maps is not quite sure which of the objects should take precedence, and hence does not know which of the events to fire.

So, it can happen that, instead of a summit marker firing a mouse-over event, an overlying “nearby region” mouse-over event gets fired instead. Which would mean that, instead of the summit info-box showing, the nearby region info-box is fired instead. Which can be confusing to the user.

Thankfully, there’s a simple remedy - turn off everything you don’t need when examining areas in close detail. So, when zoomed in, as Ed says, it’s best to turn off the nearby regions, which are only useful anyway when you’re zoomed out to the region or country level.

HTH, Rob

Thanks Rob,
One question - is the nearby regions layer turned on by default now - or, alternatively is there a way I can turn it off by default for myself - if so I haven’t found it yet and it’s a pain to have to go in and turn it off every time I use SOTA maps. Put bluntly it annoys me!

73 Ed.

Hi Ed, the simple answer here is yes: any changes in the Icons and Layers map controls which the user makes are now (since last week or so) stored in cookies. When you start up your browser in the morning and open one of the SMP mapping pages which feature those controls, the cookies are used to set the states (clicked/not clicked) of the various sub-controls within those map controls.

Of course, the user has to have cookies enabled in the browser to allow this to work.

Me too, and many others. Which is why I finally got round to implementing saving to / loading from cookies.

Thanks again Rob, I hadn’t checked the behaviour in the last couple of weeks, so now it should stay with Nearby regions turned off until I turn it on - great! (I do have cookies enabled)

73 Ed.

Hi Ed and Rob,

Thanks for your replies. My layers were set as follows:

Upon reading your comments, I tried F5 & Ctrl+F5 which did not fix the problem.
On the other hand, I removed the “Show nearby r…” layer and it now works.
It confirms Rob’s comment. That layer is on top of some of the summits near the F/AM & F/AB region and the info box for the summit will not fire-up when clicking the icon. So removing that layer is a permanent fix for me. So thanks to both of you.

Also I am sure you have noticed that the “Key” box is always on top of everything and is static so sometimes it interferes with the visibility of some menus like “Layers”. Just as an FYI but I am sure you have a giant “To-do” list to attend to.

Thanks again guys.

73,
Arnaud