Spotlite error

I cannot get spotlite to work, it just gives an error on my phone when i send the spot.

I have a Sony Erricson W810 and my mate has Sony Erricson C902 and it gives the same message. Everything else is fine i.e. Google, QRZ etc.

Anyone know what the problem is? Sean M0GIA

In reply to M0GIA:

I get the following
"Fatal error: Call to a member function fetch_array() on a non-object in /home/sota/packages/sotawatch on line 323" when I use the bookmark that used to work.


In reply to M0GIA:

New version of Spotlite and different URL? See link.



There is now a new version of spotlite at: Summits on the Air

The old version will continue to work for the time being but will be discontinued at some point in the future.

The new version, by request, has a couple of new features:

  • the ability to add alerts
  • a ‘Get URL’ button to make it easier to save spots/alerts as favourites on your phone.

It’s a little rough around the edges and does need some more work so please do let me have any feedback and suggestions and I will try and improve it over time.

73, Jon

It’s all working here but my old bookmarks are now defunct.

Steve GW7AAV

In reply to MM0FMF:
Thats the one, i thought i was in for a prize when it said Array! Nope not to be. I would really like to be able to use this function as anyone else any idea’s? Sean M0GIA

In reply to M0GIA:
Just checked my phone and im using v2. Sean M0GIA

I have heard that the new version doesn’t work for some people / on some phones.

I haven’t checked the new version on my phones, but the old version still works well for me.

Spots page:

Spot yourself:

Worth a try.


In reply to M1EYP:
ERROR: Table ‘sotawatch.sotausers’ doesn’t exist

Query was:
SELECT * FROM sotausers WHERE callsign LIKE ‘%0GIA’

Using the old page even if i spot on the pc i get that message. Sean M0GIA

I’m getting that on mine now as well. Maybe, coincidentally, today is the day that Jon GM4ZFZ has disabled the old routes.

I will now update my URLs to the current ones and see what happens.


In reply to GW7AAV:

Summits on the Air is the version that used to work for me and was the URL I used which failed.


Hi all,

I also failed to send a spot by using the old URL.

Jimmy M3EYP

Yikes, I’m in trouble here!

The old sotawatch.sota… spotlite spot URL doesn’t work anymore. The new one I can’t get to work. I get “failed to instantiate”.

My phone will only accept a stored URL of up 100 characters, so the new format is beyond the scope of that. I know that you don’t have to include all the fields, but the “ready-done” bit is half the point of using Spotlite.

The old URL to the spots page still works - SOTAwatch3


This is the self-spot form URL I tried in my phone, with some fields missing in order to keep it down to under 100 characters:

I have now got it to work, and a capital S on ‘Spotlite’ is key here.

Can anyone tell me a way to get all my info - assoc - summit - into the URL in under 100 characters?


Also, is there a new URL for the spots page? I always used:

I tried replacing the front bit with ‘’, but now I get a 404 error.

That’s easily enough changed back though.


In reply to M1EYP:
I created the url on the pc at work then emailed it to my phone then opened the url straight from the email, all details are there the problem is it will not let me post the spot.

Maybe im doing something wrong or it does not like my phones browser? I will try again later when some of my sanity has returned. Sean M0GIA

OK, I’ve got it working so that the form displays OK now.

I am using the stored shortcut URL:

Note that the capital S in ‘Spotlite’ and C in ‘actCallsign’ are crucial here.

In order to keep the string length down below 100 characters, I found that I could lose the “http://”, but still had to omit the “/callsign/m1eyp” which is a bit of a nuisance.

So, this got me to the entry form, but when I hit the “SPOT!” button, I got the following:

Fatal error: Call to a member function fetch_array() on a non-object in /home/sota/packages/sotawatch/view/classes/Spotlite.class.php on line 323

…which is the same one that Andy reported.

Any ideas?


In reply to M1EYP:
Snap! Sean M0GIA

In reply to M0GIA:

You could also use the APRS instead of mobile phones. The coverage is not perfect, but it is a amateur radio network. GPS is not necessarily needed if you use preprogrammed coordinates for the summit. Here is what I have now


73, Jaakko OH7BF/F5VGL

I see what you mean Sean. That “Fatal error” message is even returned when you use the online Spotlite form, so there must be a bug in the system.

Is anyone able to use the Spotlite v2 successfully? Can anyone still use the Spotlite v1?


In reply to F5VGL:
Neat work Jaakko, so that interfaces to your mobile/ PDA? Any circuit diagrams? Sean M0GIA

In reply to M1EYP:
Its a bit long winded but you can log on as your normal account and spot from there using your mobile i have just tried it.

To make it a little less stressful add all your relevent call signs into MY WORDS using predictive text before hand, this way you already have your call when you spot yourself i.e M0GIA/P MW0GIA/P MM0GIA/P.

Theres always a way around these things, that said spotlite would be far more convenient. Sean M0GIA