Other SOTA sites: SOTAwatch | SOTA Home | Database | Video | Photos | Shop | Mapping | FAQs | Facebook | Contact SOTA


hi can anyone help me I am trying to log in to sotawatch2 with my callsign and my password has it say to do but it keeps coming up failed so I register all my details again plus I give my self a new password but it still not working please can anyone help me because I chase sota lot in my spare time help where I can

your great fully



Hi Steven,

I can’t help you directly but a couple of questions may help me understand your problem.

Have you registered to use Sotawatch before or is this the first time you have tried to register?

If you have registered before, are you still using the same email address you were using then?

Thanks & best 73,

Mark G0VOF

hi mark yes I have registered before with sotawatch and it is the same e-mail address that I use mark


It could be that your entering your call in the wrong case. i.e 2W0JYN instead of 2w0jyn. Worth trying, it maybe something else.


What is sotawatch2? I thought there is only one sotawatch.

Confused, Heinz

just try that and still not working jonathan

it is sotawatch Heinz but it say sotawatch2http://reflector.sota.org.uk/t/sotawatch2/10331

Hi Steven,

The correct url for Sotawatch is:


Try there please.

Thanks & 73,

Mark G0VOF

There is only one Sotawatch, Heinz, but it is the second version - the Mark II if you like!


have tried there still not working

Steven, just stop for a moment please. If you have an account as 2W0JYN and you try to create another 2W0JYN then it wont work. Otherwise anyone could come along and reregister your account and become you.

We have successfully recovered your old account from the old reflector and got you working on this new reflector. That required deleting 2 erroneous accounts and fixing the email address to the new one you are using. OK. Task one done.

As you had an account on SOTAwatch before then you still have that account. You should (note should) still be able to login. However, it’s easy to mistype or forget the password etc. and then you’re stuck. I saw you emailed Jon about this and given you were already having reflector issues we’ve all assumed you were still talking about the reflector not SOTAwatch. It’s worth stating that if you don’t get a reply from anyone on the MT then there’s nobody about to reply. If you use the webform to contact us then we are 99.999999999999% guaranteed to get the message unlike email which still fails far too often. We try to answer all issues ASAP but it’s Sunday and even the MT like to take a break. We already had 7 new users sign up this Saturday&Sunday alone.

I will prod Jon directly about this and ask him to clean up the account. He’ll mail you when you can try again.

Andy, MM0FMF
obo MT

thank you will wait for his reply thanks for the help



1 Like

I’ve had a similar problem trying to register but turns out it doesn’t like the apostrophe in my surname! Though I’d mention it in case anyone else has the problem.

Colin G0CGD