SOTAWatch language

For about the last month or so when I access the database it comes up in French so Google has to translate it for me. Is there a hiccup in the system or did my uncoordinated fat fingers do something they should not have done? As of yet, I have not been able to figure out how to get it back to English. Any help appreciated.
Tim - K5DEZ

You can select language on the right hand side drop-down with all the flags

Yeah, Tim. Happened to me also - but it was in Korean. I just went */en/ a few times (or I guess you could select language from the dropdown) to get it back to something I understand better. The translations were fun though!


Found it. Fixed it. Thanks. The drop down in the upper right corner was on English but I did when I went to the database page it was still French, but I did find all the different languages at the bottom of the page. Funny I never saw them before. I must have bumped the mouse one time and accidentally changed it. Thanks again for the info.
Tim - K5DEZ

1 Like

Do you use a VPN or something that dumps you out in Europe? If you haven’t clicked on a flag before, it will do country based languages based on your network location.

Once you select a language, it will revert to that every time.

1 Like

I’m having troubles in selecting ENGLISH as my permanent language for SOTAwatch and SOTAdata. It switches back to GERMAN every now and then and I have change it manually again … diabling my adblocker and cookie addons (using Firefox browser) does not help.

Showing the English (UK) flag … but redirecting to the german URL:

When I change the flag from ENGLISH to GERMAN and then back again the webpage stays in GERMAN language. The only way I can change the language is to change the URL from to

or to

Any suggestions?

73 Martin

1 Like

My surprise language was German, but seems to have sorted itself out now.