sotawatch blank page when logging in

I signed up for an account about a week ago, but when I log in to SOTAwatch3, I get a blank page - no error message, no infinitely waiting to load, just a blank page.

When I inspect the page, I do see that Sotawatch3 has returned some HTML, but there is no content on the page. (I can post the HTML that’s being returned if that’s helpful.)

I have tried both Chrome and Firefox and I get the same result. The page loads correctly when I am not logged in, but when I try to log in - just a blank page.

I have tried resetting my password - that didn’t change anything I can see.

As you can see my account does work on reflector, but not on the sotawatch page.

I do remember having some networking issues around the same time that I was signing up for my SOTA account, so maybe there was some sign-up process that was only partially completed. In any case, SOTAwatch is totally unusable while I am signed in.

I recently did my first POTA activation, and I am really excited to get into SOTA, but the main thing holding me back now is getting a working SOTA account.

Hope someone can help.
Thanks for your time in advance!


Hi Brendan,

Reflector and SSO (Single Sign on = Sotawatch, SOTAdata, Account) are two different accounts.
So the reflector login does not proof anything.

Try if you can reach the account detail page:
Login SSO

If that is not helping you will need help from the MT.
73 Joe


The accounts for the reflector and SOTAwatch are different and so one working does not imply the other will work.

Indeed this is the problem, your SSO account is incomplete but it will have been at our end not yours.

The best way to get help with these issues is to use the Contact SOTA link at the top of this page. Right now everyone who can help you is either asleep, about to go to sleep or is me! I’m about to be away from computers for some time and can’t immediately fix your problem. I may get some time this morning or you will have to wait for the Earth to spin and my colleagues to rise from the Arms of Morpheus and fix your account.


Oh sorry about the comment about the reflector, I didn’t realize they used different accounts. I guess I must have forgotten signing up for reflector.

In any case, I tried the link you shared to the account detail page. That page appears to be working correctly. I looked over the information on the account details and nothing looks suspicious at first blush.

I tried clicking on the link from the account detail page to the sotawatch page and it still is blank.


Ah, no worries. I didn’t expect anyone to reply tonight. I’ll follow the Contact SOTA link like you suggest. Sorry, I Googled my problem and found some old posts on reflector - one that described something similar, but it was a very old post - so I assumed this was the place to ask about the issue (plus I assumed I was probably doing something dumb).

Thanks for replying so quickly!

1 Like

What happens if you open
or Sotadata3

Is your callsign shown?

1 Like - returns a page which looks normal. It seems to load properly and everything, but it doesn’t show any information specific to me. It doesn’t show anything related to my callsign. It appears the same regardless of whether I am logged in or not.

Sotadata3 - is blank when I am logged in and displays normally when I am logged out.

1 Like

Log out and back in again and it should be fixed now.


Whatever you did seems to have worked!

Thanks for fixing this so quickly and making this so easy!

Looking forward to seeing y’all on the air!


The Admin team on SOTA are amazing at keeping it going for everyone.
Hope you enjoy SOTA it has a birthday this week.
Ian vk5cz …


I get back to fix this and you’ve done it :wink: You can go to bed now.

1 Like