Other SOTA sites: SOTAwatch | SOTA Home | Database | Summits | Video | Photos | Shop | Mapping | FAQs | Facebook | Contact SOTA

SotaMaps GPX export not loading in Basecamp

Hello dear Sota friends,

I’m new here on the reflector but not to the program.
Have been activating quite some summits here and there and accomplished “shack sloth” a few years ago.

Some time ago I bought a Garmin GPS device and loaded a couple of .gpx files exported from SotaMaps into Basecamp.

Because I want to stay up to date and want to add a couple of associations I’m trying to do the same again.

Unfortunately there is an error message popping up when importing the .gpx into Basecamp. I don’t know if I’m doing something different then before or that the .gpx export files are corrupted in any way…

As far as I can tell, I’m using the latest version of Basecamp.

Hopefully anyone can point me in the right direction! I’m really keen on importing summits into my GPS system again.

Best regards, 73
Mark de PC9DB

Error message when importing to Basecamp:

Can you import a single track or route into Base Camp Mark? I don’t use Base Camp so cannot compare. The software may not accept a list of individual summit points. The summit GPX files in the SMP are not corrupt. I can import them into the Viewranger and Locus apps no problem. Sorry can’t help any more but I don’t use Base Camp.

73 Phil

I have imported several downloads from Sotamaps into different apps.

Complete region summit list files import in Oruxmaps (on Android)
Routes import into Oruxmaps too.

I just downloaded a region list (GM/WS) as a GPX and that imports into my copy Anquet OMN. The summit name, SOTA ref and heights appear in the table and the summit marker appears in the right place on the map. Anquet is very fussy of file format.

So I’d suggest the files are valid as two different apps on two different OSs work. I did have trouble importing a route the other week. It came from a Garmin GPS to Anquet and then uploaded to Sotamaps but it did have thousands of points in it, so it could have been too big.

You could try using GPS-Babel on the data. That can convert between many different file/route formats and also drive many different GPS units itself. I have used to upload files to my Garmin directly.

This is a timely post. I just ran into this trouble for the first time last night. I was trying to export summits from SotaMaps/Mapping that were within a particular radius of a place that I am planning to activate.

I found that the exported .GPX file won’t load into either Caltopo or Garmin Basecamp if the originating summit list is developed with the “Range” feature within Sotamaps/Mapping. A list derived using SOTA Regions (not using the range feature) works fine.

There also seems to be some sort of issue with the .kmz/.kml export that affects both exporting a Range or a Sota-Region. Caltopo will import it, but the summit listing panel includes a lot of ancillary information. Basecamp won’t import a .kmz at all. The .kmz/.kml works fine with Google Earth.

The Range Export feature is nice. I think it worked several months (a year?) ago. Exporting by Association/Region offers a work-around. GPS-Babel sounds interesting - that may also offer a solution - I haven’t tried it.

73,
Rob - AE7AP

1 Like

I just downloaded the GM/WS region as a GPX file from Sotamaps. Then I used an old(ish) version of GPS-Babel to push that file to my Garmin GPS. For a lot of boring reasons this version of GPS-Babel is installed on a Raspberry Pi, just accept it works the same as other versions.

  1. download region as gpx file
  2. unzip the zip
  3. copy gpx file to rpi
  4. plug Garmin Vista HCx into rpi
  5. send file to GPS with gpsbabel -i gpx -f SMP_20190227_2124.GPX -o garmin -F usb:
  6. wait a few seconds…

Looking on the map I can see all 300+ icons on my Garmin map display. I can find the waypoints in the Waypoint viewer.

Then I tried the range feature.

  1. range page on Sotamaps
  2. generated summits within 100km of Edinburgh
  3. exported as gpx
  4. unzipped and copied to rpi
  5. send file to GPS with gpsbabel -i gpx -f SMP_RANGE.GPX -o garmin -F usb:
  6. wait a few seconds

The summits all appeared on the Garmin map in the right places.

From what I have done today, I have been able to export KML formatted region data and imported that to an Android app that uses KML data and it worked. I’ve exported GPX format data and imported that into a Windows programme that displayed the data correctly. Finally I have exported region and range based data, downloaded it, copied it to an oddball setup (rpi running Raspbian) and used an oldish version of GPS-Babel to directly load the data into my Garmin GPS from the rpi using its USB interface.

There may well be a problem with Basecamp and Caltopo not working with Sotamaps files and it could be a Sotamaps issue but there ways around getting the data into a Garmin.

Rob has retired and moved to pastures-new so he isn’t here to jump on the problem as he would have in the past. Andrew @VK3ARR is a bit busy with other SOTA issues right now but will look at this when he has time (because having things that don’t work really, really bugs him). It looks like the problem is manageable in the short term.

Thanks guys for the suggestions.

It did work before so something must have been changed… We will see how it turns out!

I can download other .gpx files (non Sota related) and import them without any problems.

@AE7AP: I’ve got the fault without the range feature. Didn’t know it existed either, HI.

I will take a look into GPS-Babel because it sounds interesting anyway and may offer a solution for the time being.

Hopefully though, the “issue” can be pinned down and solved.

73,
Mark de PC9DB

Get it from:

https://www.gpsbabel.org/

You underestimate my tolerance of mediocrity

I’ve downloaded GPS-Babel and did run some SotaMaps .gpx files with the output being also .gpx.
After that, they seem to work flawlessy when importing into BaseCamp.

So there must be something in the SotaMaps generated files that BaseCamp doesn’t like.
Previously it worked so either SotaMaps or BaseCamp has changed something.

Hopefully this information helps out to pinpoint the problem.

@MM0FMF, thanks for pointing me in the GPS-Babel direction!

73,
Mark de PC9DB

Hopefully this helps:

GPSBabel won’t read the .gpx file either (same behavior as Caltopo & Basecamp) - but it gives clues. In my case (25-mile range from Helena, Montana), the error was due to the “&” character in “Lewis & Clark County” in the line for the first summit (this line describes the SOTA Association & Region). This only occurs when using the “Mapping/Range” feature. The difference appears to be in the structure of the line.

The file (using Range) that doesn’t work begins:
SOTA Association … Lewis & Clark …

The file that works (non-range) begins:
<![CDATA[SOTA Association …

You should be able to replicate this by searching a 25-mile radius from Helena, MT.

73,
Rob - AE7AP

For reference:
The GPSBabel Error Text is below:

“GPX Read error: “Expected ‘#’ or ‘[a-zA-Z]’, but got ’ '.” File: “C:/Users/R&B/Downloads/Range.GPX” Line: 28 Column: 70
Error running gpsbabel: Process exited unsucessfully with code 1”

2 Likes

Send the GPX to admin at sotamaps.org and I’ll get to it once I figure out what these things running around calling me “Dad” are.

Selecting somthing involving the following should exercise the error:

AssociationCode AssociationName RegionCode RegionName
G England DC Devon & Cornwall
W7M USA - Montana CL MT - Lewis & Clark County
VK4 Australia - Queensland SW Wide Bay & Burnett
VK4 Australia - Queensland NT North Tropical Coast & Tablelands
VK4 Australia - Queensland NH Herbert & Lower Burdiken
VK4 Australia - Queensland NF Northern Goldfields & Upper Flinders
VK4 Australia - Queensland CH Central Highlands & Coalfields
LZ Bulgaria SS Strandzha & Sakar
LZ Bulgaria PS Pirin & Slavianka
FP St. Pierre & Miquelon FP St. Pierre & Miquelon

Andrew:
I posted a description on the sotamaps.org contact page, but I was not able to figure out how to attach the offending .gpx file. There should be enough information in my posting to recreate the error.

Thank you for all!

73,
Rob - AE7AP

I meant for you to use email, but thanks anyway. I’ll see what I can do.

Andrew:
I think I finally figured it out - you were asking me to send the example .GPX file to “admin at sotamaps.org”, with the e-mail address being in a text format - perhaps so that the e-mail address is not easily auto-harvestable. If so - I have done so & also - I apologize for the thickness of my skull.

As always - thank you - the mapping page is amazing.

73,
Rob - AE7AP

Try it now. I fixed it yesterday then forgot to hit reply on this update

1 Like

It works very nicely. Thank you!

73,
Rob - AE7AP

Over here, the problem still exists.

I’m using BaseCamp 4.7.0 if that’s helpfull.

So a downloaded GPX from Sotamaps doesn’t load into Basecamp, but it does after running it through GPS-Babel.

73’

Mark de PC9DB

A bit of experimentation reveals that what Basecamp doesn’t like is the “https:” URLs in the GPX element at the top of the file. If you change all occurrences of “https:” to “http:” then the file loads OK.

Martyn M1MAJ

2 Likes

I think it’s the xmlns which is defined in the schema more than the other ones, unless Basecamp hates fetching schemas over https. I can fix this easily though