SOTA Spot Failure on Onyx Peak W6/CT-044

At around 23:30z, yesterday, on January 31, I was on the top of Onyx Peak (W6/CT-044) with my sons attempting an activation. My original alert was set for 20:00z. Noting that we were just past 3 hours from the activation time on our alert, I figured I would try to self-spot using SOTAwatch or Every attempt to spot on Onyx Peak failed. The error message from SOTAWatch was, “invalid summit identifer.” I quadruple checked that the identifier and all other information was correct, but was unable to submit my spot using both sites.

Alan (KM6TWI) happened to text me around this time, and I solicited his help in trying to get a spot out. He was also unable to submit the spot me using SOTA Goat app, and sent me a screenshot of a generic error message.

I was able to drum up a couple of contacts, but was never spotted, which resulted in a failed activation. I just tested creating a SOTA Spot on the same summit, and everything appeared to work today. This appears to be a bug or intermittent problem with the SOTA spotting system. I’m curious to know if this bug was:

  1. Downtime related?
  2. Related to me having tried to spot too long after my posted alert?
  3. Some other problem with the SOTA spot?

I assume there would be logs available. Curious to find out what happened, and thanks in advance for any investigation into the issue.

Mike (KN6EZE)

Hi Mike,

The status page shows no hint on any problem for 31st of January:
But maybe Andrew or Andy can comment on that.

There have been some changes in the database for W6

So maybe there was some missmatch or conflict in the data.

73 Joe

1 Like

There were no updates occurring at or near 2300Z. I don’t see any outages on the activity graphs. I haven’t looked at any logs that there may be for SOTAwatch. I did have a look to see what the SMS spotter was doing and it was posting spots received by SMS around that time.

Very strange.

1 Like


I’m curious if you’re referring to a software update vs. an update to the data/database. On the surface, it seems like the SOTA services (API, etc.) were functioning OK for everyone else during the time of my failed spot attempt. I wonder if there were any updates to the actual data being made during that time that might have caused a conflict. Is there any way to tell?

I would say that it was a user error on my part, but it was good that KM6TWI was able to try to spot me and received a nondescript error as well.

Thanks to you and Joe for looking into things!

I see the problem. It’s a boundary condition caused by dates versus datetimes and automatic conversions that happen. I’ll provide more details to Andy offline and fix the uploader so this isn’t an issue going forward.

Awesome! Let me know if there’s any additional information I can provide to help with the fix. Thanks for all your efforts in making such a wonderful hobby possible.

Mike (KN6EZE)

P.S. Here are some pictures and quick videos from the hike. We’ll be back there soon to do some end to end system testing :wink:

I had the exact same issue Sunday 00:00z ish on W6/CT-159

Couldn’t spot over APRS - Got a message back saying the summit was invalid.
I had cell data, confirmed I was actually on a summit, tried to spot over the web gui, no luck.
Had a local chaser try and spot me from their home - no luck.

1 Like

It’s a beaut of a corner case that now exists due to how the old DB and new DB codebases process some of the date info. The fix to the uploader is simple as well and I’ll get that in place for the next updates.

In the case of W6/CT summits they got their winter bonus extended to 31st March and that change was marked to happen on 1st Feb. You can see the change in scoring by checking the database for CT-044

From To Score Bonus
1/Aug/2012 31/Jan/2021 8 3 points between 1 December and 15 March
1/Feb/2021 31/Dec/2099 8 3 points between 1 December and 31 March

As a result of there being a hole in the time span for the summit, it appeared invalid on 31st Jan 2021 00:00:00 to 31st Jan 2021 23:59:59. That’s why various tests since show no problem when spotting the summit, it’s gone past 1st Feb 2021 00:00:00

Fun and games! :wink:


I experienced the same problem few times last year for W6 summits. I do not do anything differently now, and somehow I do not have this problem anymore.

I had the same problem on 2/1/21 around 0010 trying to spot W6/CT-205 for an activator how couldn’t get it spotted. A little while later someone else was able to spot that summit.
Jeff K6QCB

There wasn’t anything happening on Jan 2nd so that is strange.

1 Like