SOTA Maps Registration and Contact page broken

I am trying to register an account on to upload some GPX tracks for. The login page takes me to which makes me think it might use my regular SOTA username/password on for Single-Sign On, however, it rejects that login with invalid username or password even though it works directly on There is a Register link, but it takes me to a nearly blank page that just says “Registration not allowed”.

I tried reporting the issue on the Contacts form on that website, however, when clicking Send, a big pop-up appeared with a Swift Exception about unable to authenticate when sending email through SMTP.

Sotadata username and password

the problem with the contact page has already been reported and fixed - please refer to:

73 Ed.

Thanks! That worked.

It’s not terribly intuitive that the login for is the login created for and not the login used for, but it works. I also have an account for the main SOTA website so I wonder if they are trying to unite them all into one account. Not sure exactly how that will work since my login is my callsign on one site and a more general handle on the other.

Now that I’m logged in, my problem is the GPX track won’t finished the upload. It’s only 77 points total and not much else is in the same file. When I try to upload it, it shows most of the points, 69 of them on the left column, but has a pop-up with “Checking uploaded file…” that never goes away or finishes. I can’t seem to save the track until that’s complete. I’ve tried both Firefox and Chrome so it doesn’t seem to be a browser or cookie issue on my end.

The database user data was chosen for the single sign on as it was the most complete set of data we had. People participating in SOTA have a database account, but not all of them use SOTAwatch or this reflector or the main SOTA site. Many US users, for example, never come on here so the user details from here would be of less use.

There may be issues from the database userdata but nothing that cannot be solved. The problem as always is conflating information needed to identify an account (login username) with display name. The database handles it by you having a login name, the username, and a callsign field that is used in the honour rolls etc. The same data can be used elsewhere. But as I said there may be issues that might need things editing, tweaking etc.

Just altered the tooltip on the SMP “Login” button to inform people that they should use their sotadata username and password when logging in to sotamaps/SSO.

Not sure if many will notice it, but at least it’s there :smiley:

I am having a similar problem. I managed to log in to Sotadata and upload several tracks, but there is one specific track that fails to upload. When I try the upload, the pop-up “Checking uploaded file…” never goes away or finishes. I am using Chgrome on Win7. I loaded the track into several programs (MapSource, OziExplorer, an online gpx conversion utility) but neither produces a gpx that passes the checking stage at sotamaps upload.

73 Fric

Hi Fric,

PM me and we’ll take this further.


OK, so I’ve discovered the source of the error when the tracks page does not upload certain tracks, and the “Checking file” message does not clear.

It turns out that this happens when the recorded GPX track contains no elevation data for the track points or, more accurately, the elevation for each point in the GPX file is set to zero.

I’ve altered the code so that this should no longer be a problem.

In the next few days, I’ll integrate into the page a call to our own elevations server (as is used in the SMP range page Elevations Profile tool) and overwrite any zero elevations with proper elevations data for each point.

HTH, Rob

Thanks Rob,

Yes indeed, this track had all elevations set to 0. It was not recorded by the GPS unit originally. Instead, I drew it with GoogleEarth, as an alternate route while preparing a recent activation.

73 Fric YU1WC