Other SOTA sites: SOTAwatch | SOTA Home | Database | Summits | Video | Photos | Shop | Mapping | Sotlas | FAQs | Facebook | Contact SOTA

SOTA Mapping 2W0CPX callsign not recognised

I can find my activations as 2E0CPX but when I search for 2W0CPX it says the callsign is unrecognised?

That is normal, you have one account and all your activation’s are in the same account !
Look here at SOTLAS

73 Eric
F5JKK

2 Likes

OK, I can explain this. When using the sotamaps activations mapping page, the user always enters the callsign with which they registered in the SOTA system - on your case, that’s 2E0CPX, and not 2W0CPX, or DL/2E0CPX/P, or whatever.

After you’ve entered your registered callsign in the activations page, the program seeks out any activations you have made, up until the time that the background database available to sotamaps has received its’ latest updates. Such updates occur, AFAIK, once per day.

You made your very first Welsh summit activation yesterday, and the details of that activation had not yet percolated into the sotamaps database copy at the time you checked last night, so you did not see that activation included in the list.

In the intervening time, the sotamaps copy db has been updated, and you can now view that latest Welsh summit activation.

Future versions of sotamaps will:

  • use the LIVE database, so such problems will no longer occur, and
  • there will soon BE no sotamaps, since it’s functionality will be included piece-wise into the SOTA “Database” site, and sotamaps will be closed down.

HTH, Rob

2 Likes

One further note - the very excellent sotl.as is able to access live data, but only by means of using the API provided by SOTA, which provides data in a given format but, correctly, no “naked” access to the live DB. At the time sotamaps was built, there was no API, and sotamaps had to use its’ own very limited home-grown database.

For a few years after, the API was slowly developed to provide a very limited number of queries - the SOTA IT guys then decided to provide a copy of their live DB to sotamaps, but at a price - it would always be a maximum of 1 day (or occasionally more, when the inevitable glitches occurred in data transfers) out of step with the the live data. Sotamaps then used it’s own SQL queries on the copy DB, instead of API calls to fetch data.

Now that the API has been fully developed (with room for more API routines in the future) providing live data at arm’s length, sotl.as quite rightly uses the API - which has actually been developed hand in hand with Manuel’s requirements - to provide sotl.as with the data - LIVE data - it requires.

3 Likes

It is working now, so as you say just needed time, however, it has totally missed an S2S, how do I correct that? I have tried entering the coordinates for G/NP-005 but it keeps saying enter the correct latitude.
S2S Moel Famau

1 Like

You’re right in saying that the S2S contact is missing in the QSOs listing, and in the map, for your latest activation in Wales. But those details are missing also in every one of your other activations listed by that page.

This also happens to me and my activations … but it wasn’t always thus. Before the sotamaps site was handed over to the SOTA IT people, all of this was working properly. Lately, however, discrepancies like these have cropped up, and are rather annoying to say the least.

I just now tried to login to the SOTA one-time login via the sotamaps site, in order to further look into this, but I find I am unable to … is anybody else having these problems?

EDIT - I’ve found sometimes that activating the time charts in the activations page can “trigger” a lookup of the S2S QSOs, but this is at best indicative of instabilites in the newest version of the code.

1 Like

I have just looked at my previous activation at Shining Tor and the three S2S are missing which is


strange because they were there!

2 Likes

Yes, as I say, there seem to be peculiar inconsistencies in the code being used now which, among other things, may or may not show S2S QSOs, and which very annoyingly will not show QTH/summit icons until several minutes have passed … then they appear as if by magic.

Not very helpful to the user, but - as I have hinted above - the days of sotamaps are numbered, and we can all look forward to the day when this kind of activations/QSOs/mapping will undoubtedly be perfectly rendered in some new page in a SOTA site - or in sotl.as - which is probably being developed as I write…

The future looks bright indeed!

2 Likes

Well you know something I don’t, I did say the other week when it was working it got a “Wow” award from me!

1 Like

Well, that’s indeed nice to hear! I’m sure the SOTA people will be glad to hear that.

Best of luck with future activations, and stay safe!

It appears that the gods have been kind to us - S2S QSOs are now being listed again in the SMP activations page, and the charts also appear to be loading in the background - there have been some problems with charts loading recently. SOTA SSO login is also working again from within the SMP pages.

There’s still the problem of the QTH and summit icons taking several minutes to appear, so let’s hope the icon god can sort that out soon…

3 Likes