SOTA Cluster updates 17/12/2023

I updated the OS that powers the cluster last night from Debian 11 to Debian 12. I’ve done this on several machines now and it went smoothly, it takes about 15mins. What I always forget is that the version of Python gets updated when you do this and then I need to manually update the extra Python modules used. This used to take another 5-10mins. However things have changed slightly so there was a bit of panic whilst I figured out how the new way worked. So the cluster was offline for about 25mins in total and is now back in service.

But… I noticed that twice it stopped sending spots to a computer I was using to monitor it. I don’t know why and I don’t know if it is the cluster or the monitoring computer. I’ve got some tests running to see if I can find what is different now (other than ALL the software :frowning: )

If you find that your feed of spots dries up you can try adding the following command after you login.


This will cause the cluster to send the prompt “<call> de MM0FMF sota_cluster >” every 5 minutes.

Let me know if you have any problems.


If it is helpful Andy it seems to be behaving here (Mac running MacLoggerDX). Thanks for the service! 73. Paul

1 Like

Thanks Paul. I have 2 connections running that have been active all day. One is on a VPS in Switzerland and that has no keepalives or similar and is working fine. It should do because there’s nothing that requires traffic to keep the connection alive. The other is a computer in the shack where the spots kept freezing. That had the PING5 command today which means there is traffic every 5mins. That is also still connected working fine. So it was probably something to do with the router here and / or my VirginMedia connection. I don’t remember it doing this in the past.


Thank you for all you do for us!

Kent K9EZ

1 Like

Experiments concluded, everything seems OK. The problem with one computer’s feed freezing was solved by getting the cluster to self-keepalive with the PING5 command. There was another issue on the SMS remote server that got the wrong JWT (Java Web Tokens) library installed and failed to verify incoming connections. That’s solved too but leaves me some work to do over Christmas to make the solution elegant.

Finally as expected the volcano near the data centre in Iceland has started erupting but is not affecting anything yet.

Note to self: next time a big upgrade is scheduled, check the effects on a test system first so you don’t futz the live system. And hey it may have worked the last two times without issue but there’s always times like this waiting for you !


Thanks for the good service!
73, merry XMAS and HNY
Martin DF3MC

1 Like