Other SOTA sites: SOTAwatch | SOTA Home | Database | Video | Photos | Shop | Mapping | FAQs | Facebook | Contact SOTA

SMP updates

Thanks for the error report Andy; but I have to say that you’ve here made the same basic mistake ALL the other good folk make when reporting an error, which is to neglect to tell me on WHICH PAGE the error occurred. :older_man:

Nonetheless, I’ ve been able to repeat the error (it was the MAIN page!), and fix it. Just do the usual (sacrifice a chicken - tandoori will do in a pinch - while chanting the SOTA User’s Manual backwards), and hey presto - whiter than white!

To be fair, he did give you a really good set of reproducer steps there.

Seriously?

Yup. My work laptop is due for replacement next April when I’ll get a 7th gen i7 with a 4k touch screen and Win10 Enterprise. Till then Win7 Enterprise 64 is used. Of course, it only runs Outlook and Office and web browsers & X displays, I’m not allowed to develop on it any more. Development is done on farms of servers here and in Germany/US. So many machines running so many versions of Windows (7/8/8.1/10) and Linux (RHEL, Centos, Ubuntu) that I lose track of what I’m using a lot of time!

Absolutely, I’m just pulling Andy’s leg. It’s more a gentle reminder to others to please include more information when reporting errors, because virtually none do so.

Well, I’ve received no indication that the rectification to the problem mentioned above actually produced the desired result, so I’ll assume the fix has worked for everybody. So I can delete the ticket…

Good Morning Rob

I don’t think you have announced this, but I see a really good enhancement has been made to the mapping pages.

Bill G4WSB is currently activating in the FL/NO region where a number of summits have never been activated before. I notice that the unactivated summits (such as FL/NO-053) from where he now is, are now splendidly picked out in red, thank you. Red Highlights

73 de Phil

Hi Phil and all - this feature is months old! I’m sure others have seen this and thought nothing of it at all :wink:

But I’m glad you like it and it is, as you suggest, another useful tool in the SMP for users to identify summits to activate.

PS - There’s a lot more coming, quite soon…

FB Rob - guess I must have been looking at areas where the summits have all been previously activated, hence I hadn’t seen it before. Good news about further enhancements!

I see the new location for Hensbarrow Beacon is shown on the mapping - G/DC-008 - I wonder who will be the first to activate that “new summit” on 1st Sept??? As a chaser I will certainly be looking out for it coming on the air…

73 Phil

Hi Rob,
I noticed it a long while ago and found it to be an excellent feature! Sorry, I didn’t give you any feedback!
I always use it when we plan our activations in new areas!

Thank you very much for the constant advancement!

73, Sylvia

2 Likes

I downloaded several “KML Network Link” files from SMP … this way I can have a look at all the summits on “Google Earth”. Unactivated Summits are colored in red there too!

73 Martin, OE5REO
www.oe5reo.at

1 Like

Hello Rob

Another change to the SMP noticed (Probably been done months ago but unnoticed by me):

Short tracks now permitted to be uploaded - great! I just imported a short track walked last week up to Nedvezi OK/LI-053.

Thank you very much Rob for this useful feature. Activating is not just about the walk - the likely start point - even on a very short walk such as this one of just 200m from the car parking place, is I hope of use to future activators.

73 de Phil G4OBK
SOTA Mapping Project Contributor

73 Phil

1 Like

Hi Phil,

Actually this is a very recent change, implemented only last week, and following a request for such a feature from another user. Glad you find it useful.

Cheers, Rob

1 Like

Great stuff - onward and upward Rob!

73 de Phil

Rob, you have probably noticed that Google Maps behaves a bit differently than it used to do. I noticed this on some other websites over the recent weeks. However, it seems to have arrived on SMP today. It wasn’t behaving like this earlier this week.

Google have changed how the scrollwheel on the mouse works with their maps. For a long time, the default was that the mouse scroll wheel changed the zoom level. Now the default seems to be a message “use ctrl+scroll to zoom the map”. Only if you hold ctrl down at the same time does the zoom work. I’m a bear of very small brain and I’m used to just scolling so this change by Google bites me badly. I believe it’s possible, if you are using the right version of the Google API, that you can request the old way of scrolling, i.e. no ctrl needed.

Could you possibly have a look into making scroll work the way it used to when you get a free moment? Thanks.

Yes, I’ve seen this myself on a few sites, and wondered whether, or when, it might show up of its’ own accord in the SMP. I just did a forced refresh of the both the main and range pages in the SMP, and used two different types of mouse, and I’m still not able to see the message about using Ctrl+scroll there.

Nonetheless, you (and probably others) ARE seeing this, so something has to be done. Fortunately, the fix is a simple one, which I have now implemented. Although I don’t see any difference, perhaps you could try it now and see if the message goes away… A full refresh of the page will be needed (Ctrl+F5, or Cmd+R on the Mac).

Rob

So firstly and most importantly, I didn’t say which browser and OS which I should have done. I was using Firefox (52.5.0 ESR 64bit) on Win7Pro.

I got a message from Christophe ON6ZQ saying it all worked fine for him and was it on all browsers. So I tried IE and it worked fine. Was this something now Firefox specific as I do have a plugin or thirty running! Anyway I came here to say I should have said Firefox etc. and saw your message. A good hard cache flush and reload and it’s fixed. Thanks, that is such an improvement.

I had a busy year last at work and was unable to take all my vacation days. This means I have a load of extra vacation to carry into 2018 and I’m planning a few SOTA expeditions. (FL/VO is one, F/CR & F/PE is another, maybe LA/FM + OH/MU) I have been doing some serious map scanning and the change to the scrolling was driving me insane. But it’s back to how it should be now. Again, thank you.

Using here Firefox 57.0 on Win 10 Home 64bit; also tried it in Chrome 62.0, Opera 49.0 and … Edge: don’t know which version since the menus are so cocked up on that pile of excrement, that I can’t find the version number. Nice helpful piece of software, I hate it almost as much as Outlook (which I only have to use at work).

Oh, BTW, if you don’t already know of it, you might try the SMP user-zoom function in the maps, which could save some scroll-zooming and -panning. Right-click the mouse and hold down near an area of interest you want to zoom into, drag the mouse to draw a rectangle describing the area of interest, release the mouse. Voila, you zoom into the area if it is possible to do so. Pressing <Esc> at any time during right-click-drag will cancel the action.

1 Like

I’m on the ESR release branch of Firefox as a number of plugins and addons were not compatible with the new API in FF 57 some weeks back. I jumped to ESR branch so I could still use what I wanted whilst the bugs in the new API for addons could be tested by many. I’ll probably move back in a few more point releases as FF57 is meant to be much faster and better on memory.

Super zoom… :thumbsup: