Other SOTA sites: SOTAwatch | SOTA Home | Database | Video | Photos | Shop | Mapping | FAQs | Facebook | Contact SOTA

SMP new version goes live!

It is the sotadata username and password. Please don’t go creating new accounts

(Although it is possible, your existing activations and chases from your existing account will not be tied together if you register a new username).

Within SSO, there is the ability to specify your Callsign and Association.

As per everything from the internet involving email, I’d suggest checking your SPAM folder.

The only drop down boxes are these which animate a drop down dialog box . Can it be disabled so the dialog box just appears.


The chosen summit box starts by displaying summit xx-001 then scrolls down to the summit selected when you click on a summit on the map. Can it be disabled so it goes straight to what you clicked.


I will have a look in the morning at the logs to ensure a email has been sent. I’d go and look now but I have a simple rule… If I have been drinking (and I have since early as it’s Christmas Day), I don’t log in and access the admin facilities of the database because it’s easy to do something unintended when the demon drink is running wild through my veins.

1 Like

No, this is on the SSO side, not the db mailer side

See, that’s why I don’t touch the admin pages when I’ve been at the sauce!

As an aside the user name for this user contains chars outwith ASCII 0x1f-0x7f, will that be a problem Andrew?

1 Like

It should be fine - UTF-8 is the default dataset.

Still no luck :frowning: Tried the F5 and Ctrl-F5 and a few other things.

I’m able to log in to the Main SOTA site using my Callsign and password. However, my Database User Name is not the same as my callsign, and to log in to that I need to use that non-callsign User ID.

I cannot log in to the main SOTA website with that non-callsign User ID; if I try that it tells me “Sorry !! We cannot find a user with such information”. On the other hand, I cannot log in to the Database website with my callsign; if I try it tells me “Invalid User Name or Password”.

And on the mapping site, I’m not able to see an option to either log in or log out, and it does not appear to be dependent on whether I have first logged in to any of the other websites or not.

Sorry to be that guy who has to be a PITA on this! But I use the maps site pretty much daily, making plans and uploading tracks etc, so I’m lost without it! I know, I should have just made the original user id’s all equal to my callsign, but when they were all separate and I was a SOTA newbie I didn’t realize it might cause problems later.

BTW I’m using Chrome on a Windows 10 laptop currently. I have other machines that I can try but they won’t be accessible to me for a few more days.

Thanks and 73,
Keith KR7RK

More info…this same error message comes up (“KC init failed”) when I try to log in under either Google Chrome or Microsoft Edge. I was able to load the maps page under Edge (not my normal browser), and it showed the login button. Tried to log in using my Database Username and pw, and it said invalid id or password. Then tried to log in using just my callsign and pw, and then I get the dreaded KC init failed error and no longer see a login button.


OK my apologies for all the bandwidth!

I believe I have fixed my issue. Cleared cookies and was able to find a combo that worked. I still think I have an issue in the SSO system due to callsign versus Username being different, but at least I am in the maps now.

Thanks and 73,
Keith KR7RK

Your username is your sotadata username. Your password is your sotadata password. Callsign is not relevant here.

It’s the same for me, and for many others whose user-name is not equal to their callsign. But in my case, and I suspect in others’ also, the confusion lasted a few minutes only. Stick with it, it’ll grow on you. :wink:

Not true! Those “drop down boxes” are custom Google Maps controls which, by virtue of the way they are coded, just happen to cause a small dialog box to appear/disappear on demand.

The real dropdown boxes are those which allow the user to choose things like Association, Region or Summit from an often lengthy list of options. And there are many such dropdown boxes scattered throughout the several pages of the sotamaps site. Hence my confusion as to which dropdowns you might possibly have been referring to.

So, we’re talking about the map controls, and you wish me to cause the small dialog boxes to appear instantaneously, instead of taking the programmed 120 milliseconds to appear? This could certainly be done, but since I’ve not heard a whisper of complaint from others concerning this feature, I’m wondering why I should spend time attending to this in order to satisfy the whim of one particular user?

Moving on to your second request, that the auto-scrolling in the left-hand listing of summits should also be disabled: there’s actually a reason why this is done, rather than it’s being just a piece of “designer’s flair”.

The reasoning, such as it is, is as follows: if the summits list for a particular region is quite long, the chosen summit might be a long way down in the list. If the program were to cause that chosen summit to appear suddenly by scrolling instantaneously to the appropriate line, the user may become confused as to the position of the line within the list. Remember, we are dealing with users of all abilities here, and not everybody is conversant with scrollbars and scrollbar-thumbs; so I try to accommodate such users by showing the list scrolling down, acting as a visual guide, so that they can get a good visual estimate of where the line is in the list.

Having said all that, I suppose I could include a new row in the main page settings dialog with control(s) allowing the user to enable/disable this auto-scrolling of the left-hand main list. Here’s how it would go:

  • create new row containing a checkbox with unique id in the settings dialog code;
  • create new subroutine to capture the click events on the checkbox: this subroutine would, on each user-click, update the entry in the browser’s local storage for the SMP main page;
  • alter the code which populates and displays the list to refer to the state of the checkbox and either cause the list to scroll or not;
  • alter the startup code for the page and, on page load, to set the state of the new checkbox to agree with the setting stored in the browser local storage.

Like most things in website maintenance, it CAN be done. The question is, SHOULD it be done? Does anybody else have problems with the auto-scrolling of the list?


1 Like

Logging into the new SMP website works with MS Edge, but not with Google Chrome 71.0, despite having cleared the entire browsing history, including cookies etc. When clicking the “Login” button, I get this message:
www.sotamaps.org says
Cannot access SOTA SSO server.

I just tested this in Chrome 71.0.3578.98 64-bit on win 10 - it works as intended.

EDIT: however, during testing of the site, I would occasionally run into this problem, and it was caused by my having refreshed the page too often using the browser F5 or Ctrl+F5 combinations.

The remedy was to delete from the browser’s URL-address line everything to the right of “…sotamaps.org” - it’s a clunky solution, but it does work. In doing this, the text that gets cleared out is that which has been appended to the sotamap site’s URL by the SOTA SSO system.

Tnx Rob, using same versions here:
Chrome Version 71.0.3578.98 (Official Build) (64-bit)
Microsoft Windows [Version 10.0.17763.195]
Also tried truncating the URL as you suggested, but still no luck.
After XMAS there will be many more OMs trying and finally someone will come up with a solution.

OK Markus, thanks for the details. I’m sorry to hear you’re having difficulties with the SSO server. So, a couple of questions:

  • are you having the same problems using a different browser?
  • are you already logged in to the SSO via sotamaps or via the newsotadata site?
  • are you having the same problems in the newsotadata site?


Well, the solution will have to be found by one person - Andrew VK3ARR - who is responsible for the SSO server and SSO integration, and who monitors this thread when he can find the time.

Nothing in the logs - could you provide screenshots by private message to me, please @HB9BRJ

Rob, referring to your questions:

  • no problems when using MS Edge
  • previous successful logins via sotamaps and newsotadata
  • no problem to log into newsotadata after having solved the riddle :smile:

Update: Problem solved. Browser extension “Privacy Badger” caused the problem. After disabling it on the SMP website everything is working fine!

Thanks Rob and Andrew for your great support.
73, Markus HB9BRJ