New SpotMySota v.4.0 app -> Now 4.0.1

Hi ! After 16 years of developing the first version of SpotMySota, I have rewritten all the app and it is now available the new SpotMySota 4.0.

It is a simple and robust app to send activation spot by SMS. Sotawatch config/password can be used and it has also the option to send with Andy’s MM0FMS format if your phone is registered there.

Optionally, you can enable GPS function in the config to see your altitude, the distance to the summit and a topo map.

So, a simple app without flourish to fill 4 fields and spot.

Thanks go to Mikel EA2CW for helping on the app design and his infinite patient on helping with the debuging.

SpotMySota 4.0 can be downloaded from:


Merry Christmas and hope to listen you on the summits !

73 de Iñigo EA2CQ



Do you plan to add the VK SMS number to the app configuration?


Andrew VK1AD

1 Like

Sure, if the VK SMS gateway is compatible with OE5JFE SMS gateway format it should work. Confirm the number in that case.

1 Like

The VK SOTA SMS gateway is compatible with Andy’s MM0FMS format and requires registration with Andy.

Details are at Help:Sending activity spots via SMS

1 Like

Tnx info… I have just released version 4.0.1 what includes the VK Gateway.

No need to uninstall version 4.0 if it was installed.

Enjoy !

Thank’s for this Christmas present Inigo.
Gerald F6HBI


I just tested the SMS spot…:2 things
On the “Latest spots” page display EA SOTA Spotter
the time is not Utc (Time EA)
second: My spot is shown on the page, but not on the sotawatch (may be because of the “test ignore” comment?

Guess there is a bug somewhere…!(now resolved)
I can send a SMS via OE Gateway, and also via EA gateway, that is OK.
But when i use the application, the Spot is shown on the EA gateway dashboard, but nothing on the sotawatch page.
… (resolved), Gerald

1 Like

Hi Gerald,

Well, everything seems to work fine.

  1. Dashboard shows EA time as expected. (Show header “EA Time”)
  2. Your first SMS arrived BUT it seems your phone is not registered at MM0FMF SMS Gateway, so, it has not been pass to Sotawatch. (MM0FMF option ticked on config screen)
    Your second message was sent directly by hand using sotawatch user/password format and it appears ok at sotawatch:
    Your third message was sent again with SpotMySota but again ticket MM0FMF SMS Gateway on config, so it arrived to the gateway but no passed to Sotawatch.

So, just go to config screen on SpotMySota, untick MM0FMF Gateway registered and try to send again your spot.


1 Like

Thanks Inigo,
All working for me, using Android 11 and SMS being sent direct to UK SMS gateway.


73 Ed.

1 Like

Thanks for the tip (tick box must be blank) but as i can remember i registered to MM0FMF SMS Gateway, long time ago.
Let me try again…qrx
It is Ok now without the tick box (Phone registered)
Thanks for helping.
Have a nice Xmas evening Inigo

1 Like

Perfect! I have already seen your test spot at Sotawatch. Merry Christmas !

Go to your SW settings and untick the “Ignore test spots” that you must’ve ticked ages ago and forgotten about now you actually want to see a test spot :slight_smile:

1 Like

Done! Thank for the remember.
Xmas, Gerald

1 Like