Mapping - Activation error

I seem to have an error coming up when I try to access the activation map in ‘Mapping’. I know I can see a map within the database but it doesn’t have the mileage or detail. I’ve also a spurious QTH for one callsign off the Horn of Africa. Details below

Hi Paul,
If you haven’t already done this, try pressing ctrl+F5 and wait for the complete to reload. This includes the executed in the browser, code and then try again.
I had a similar error yesterday but once I refreshed, all was OK. of course as always YMMV …

73 Ed DD5LP.


Yeah not having any joy with this.

Paul G4IPB position data was wrong putting him in the Indian Ocean. I swapped them but he’s not yet moved on the map. I tried re-uploading your activation to see if that would move him but it didn’t. There’s something else needed to make the map positions update.


…that sounds like I have made a significant navigational error… can you let me know where I have got it wrong?
Paul …( sounds like I’m off to activate the twin peaks of Kilimanjaro in Norfolk….)


My memory is not as hot as it was. I saw you were located in the Indian Ocean for a map and that’s indicative that you had the lat and long swapped. 53N 2W (NE England) becomes 2N 53W (Indian Ocean off Somalia). I’m pretty sure I swapped them for you. Then when Paul (OSB) mentioned his map I thought “ah Paul (IPB) will have fat fingered the coords.” But they looked OK till I realised I’d missed out a minus sign and had you at 53N 2E (North Sea) not 53N 2W (NE England). These coords are set when you register and you’ll find them on the “Update Account” page.

The preferred format is decimal degrees. i.e. 53.847222 not 53° 50’ 50" and positive numbers are North or East.

53.847222 means 53.847222 North of the equator
-53.847222 means 53.847222 South of the equator

4.7655 means 4.7655 East of Greenwich (0 longitude)
-4.7655 means 4.7655 West of Greenwich (0 longitude)


I think this is happening a lot. Any chance to add a map with a preview of the location (with a coordinate picker there)?
Or just calculate the locator. This would for some people trigger the notion that something is wrong?

73 Joe

That’s a nice idea. However, we’re technically qualified people (we did an exam to do our hobby) and our hobby is communications. We should be able to type a few numbers in the correct order in the correct place or how will we be able to communicate with our friends over the air? :slight_smile:

1 Like

I fully agree Andy. The technical qualified is wishfull thinking… I sometimes get confused with lat and lon (I like maps and GPS stuff. But in German it is as irritating Längen und Breitengrad)

But as a (n amateur) programmer I know that users will always find a way to break it or at least complain about things :laughing: .
Just thinking on what is more efficient longterm? Fixing the coordinates in accounts again and again or handling reflector threads because again someone got it wrong?

Let’s have a drink at Friedrichshafen :beers:

1 Like

Technically qualified people still make mistakes. It’s easy to swap figures or get lat and lon mixed up. If there was a way to check the location you had entered was correct then it would reduce these errors.

1 Like

…just a thought but could it calculate the locator (IO84 etc) as a check system as reversing anything would result in a more obvious error…
Sorry for the mistake, I’ll blame my fat fingers…It is probably a good job I’m not an airline pilot….

1 Like

The profile and registration piece is handled by our SSO server which doesn’t allow a lot of detailed context-aware troubleshooting. To fix that, I have to write a Profile page and call an API. It’s low on the priority list right now, as I should probably find time to do this SOTA activating thing people keep talking about.


I know. If I had made fewer I could have retired sooner !

You need to boost your association count :wink:


Thanks for all your hard work, it is really appreciated. I didn’t mean to break it… honest! Enjoy the hills not just the keyboard….

1 Like

I suspect the reason people get lat, long wrong is everywhere else we talk of positions in terms of ‘X,Y’, but lat, long oordinates are ‘Y,X’.

I worked an IT project that reversed lat and long globally throughput the whole system whe reading as writimg data. Thats to say all 3 developers got lat and long back to front. And as they were consistently wrong, the errors all cancelled out. The mistake was only picked up when I directly queried data from the database.

1 Like

You, sir, are an ideas man!


It’s often been said that we are a technically gifted bunch of people - and that is certainly true - but being technically gifted is not the same as being observant, at least not always.

If I’m reading the comments correctly, it would appear that the mapping of activations in the SMP sometimes shows a chaser’s QTH as floating somewhere in the ocean, instead of where one might expect it to be located?

If this is the case, then here is where the “observant” part kicks in - in the SMP activations page, there is a button curiously labelled “Set QSO QTH…”. After a user has highlighted a QSO in the activation QSOs list, this button can be activated to open a dialog where the user can set the missing or bad QTH for the other station.

The QTH position can either be entered as text (copied from e.g. the chaser’s page), or by clicking on their QTH location in the map. Once entered, this QTH position is available to all other users who may have had a QSO with that other station. Oh, and the locator is automatically calculated from the inputs.

This is all explained in the SMP activations page help which is artfully hidden behind another button labelled “Help…” - but who ever reads the manual, right?

1 Like

It’s the mapping of an activation in the database not in SMP. For example, for my activation of G/NP-005 on 11/5/23 the database shows DL8MF in the Arabian Sea but the SMP has him in Berlin. I believe the reason for this is that the database uses the lat/lon entered by DL8MF in his SOTA settings and this has been entered wrongly.

OK, Richard, thanks,


Well I’ve tried everything and the same error message comes up. The one change is that my last activation appears twice.