Other SOTA sites: SOTAwatch | SOTA Home | Database | Summits | Video | Photos | Shop | Mapping | FAQs | Facebook | Contact SOTA

Is it safe to enter new logs now?

Hi all,
is it safe now to submit new logs to the SOTA database?

mni tnx fer clarification!

73 de Martin, DK3IT

Hi Martin
I have done all mine this evening, and all is OK.


I am having problems right now. Lost the ones I uploaded last week too.
73 W1DMH I am getting this error
System.NullReferenceException: Object reference not set to an instance of an object. at SOTA.AddActivation2.Button1_Click(Object sender, EventArgs e) in c:\SOTA\SOTADATABASE_Net45\AddActivation2.aspx.cs:line 218

When you log in, is the title at the top:
“SOTA Results and Summits Database 2018”?

If not, then you’re still on the old system and your DNS hasn’t updated yet (or is heavily cached somewhere).

You were too slow possibly and got logged out. Log in again and you can continue from where you left off.

This is what it says.“SOTA Results and Summits Database 2018” I am using a work laptop that I usually don’t use, for SOTA logging. I have not had luck with G0LOGS CSV editor recently, ODB (?)driver problems. So I was trying from work :wink: Thanks for all your work. :slight_smile: Now I am looking for a new editing program :frowning:
73 Doug W1DMH

Hi Doug,
As regards the SOTA CSV editor from G0LGS, I’ve just checked and there’s a new version (Version you might like to try to install that and see it gets rid of your MS Access database error. Then again you could try running CSV2MDB so that it load a new summits database for you.

73 Ed.

Ed, Unless the new version is in the last week, I should be up to date. I will see if I can do whatever CSV2MDB is when I get home.
Thanks and 73 Doug W1DMH

I have submitted 2 chaser logs and 1 activator log some 30 minutes or so ago and they are still there. Everything seems to be OK now.


Hi Martin,
I waited for the local DNS system to get the news about the sotadata site till the last night. As soon as it happened, I entered data about my three recent activations and it looks like my updates are keeping steady. So, I guess, it is now safe to enter your activation data, too.
GL & 73’s!
Zoran / E70AA

You should check "Fast Log Entry"

73 Martin, OE5REO

Well I don’t see a date but as the help screen says Copyright 2011-2018, I suspect it’s from this month:
However the previous version worked file for me as well.
I hope just reloading the database will help. Otherwise you could try to de-install and re-install the program, that can often fix issues such as another program overwriting a SOTACSV Editor required file.


1 Like

Just up loaded mine no problems :slight_smile:

Thanks, all - maybe a moderator could pin a short message stating this to the main page.
I think this would be useful for many users.

73 de Martin, DK3IT

Ha, well that would tempt providence!

There was a message saying the DB was open and it was pinned.

There were reports of some people having access issues, most likely stale DNS info and that is now fixed. The DB did run gruesomely slowly for a period but that seems to have fixed itself.

From my tests, the actual DB engine is much, much, much faster than before. The web server (the bit you all interact with) seems slightly slower than the previous version. But, and I stress but, there is probably a lot of behind-the-scenes work taking place as other customers are migrated.

From my point of view… automated backups are working. I have them being fetched again. AM reports and summitslist.csv generation is running and the daily temp files clean up is working.

As we stand, the DB should be consistent up to 0600Z 24-jan-2018 and from 0800Z 28-jan-2018. That is 98 hours missing by my book. I still have to confirm what data I can fetch from any backups I may have for that window.

Can you use it? Yes. And maybe it will work UFB :slight_smile:

As always it is your responsibility to ensure you have backups of your logs. For info, the backup I do runs automatically every 0400Z. That backup and the backup from the day before sit ready for immediate restoration on the server. At 2000Z another computer (different OS, different host, different data centre, different continent!) fetches today’s backup and deletes yesterday’s backup. This means I always have a backup no more than 24hrs old ready for restoration. And can copy any backup from the last 30 days or so for restoration. On top of that I have end-of-month backups for every month over the last 18months plus end-of-year backups dating back to 2012.

Finally, a number of people have been in touch essentially saying “I get great enjoyment from SOTA and after the DB problems, I’d like to donate some money to ensure everything gets funded”. The aim of SOTA is to remain free at the point of use and funding comes from selling merchandise and awards. However, if you want to donate the facility does exists, using it is entirely up to you.

At the top of every page is a line of links, one of these says “Shop” (https://sota-shop.co.uk/) and on the shop site you will find a donations page (https://sota-shop.co.uk/donations.php).


ODBC problems are almost certainly a problem with your Operating system configuration as my SOTA CSV Editor does nothing to change the default ODBC configuration, but it does need it to be working in order to convert the Summits List CSV to MDB or use the resultant MDB file.

I believe SOTA CSV Editor should work without ODBC at all, but you will probably have to delete any SOTA_REFS.MDB file from your SOTA logs folder (i.e Documents/SOTA Logs) so that it silently fails to open it.

Stewart G0LGS

1 Like

And in the way of computers…SOTA CSV Editor, suddenly it works again, for me. Not in apparent response to anything I have tried. This makes my day, on top a blue sky -10C 13 point activation :slight_smile I love how it makes logging soooo much easier, and fixing logs a snap.
73 Doug W1DMH

Did you reload or update the database Doug?

73 Ed.