** IMPORTANT** Database Migration ** IMPORTANT**

Bah! It’s obvious when you know how that clever chap VK3ARR works :slight_smile:

Uploads temporarily disabled

Thank you for participating in SOTA 

Andrew disabled writes to the DB on newsotadata but the web site remains active so you can use the site to access existing information. This is much cooler than the old site which has very simple access control… all or nothing!

Currently newsotadata is pointing to the old DB because Andrew would have been asleep when I gave the all complete for the migration. He’ll wake and smile at me being a bit slow on the uptake, flip to the new DB and allow writes and then smile some more.

Panic over :blush:

Thanks for the investigation Andy.
All good then!

Time for some rest :sleeping_bed:

It’s June and the sky is 25% cloud covered. My shack window looks North West and at 55.9N it never gets dark… only twilight. So I look out of the shack and see quite a bright sky and glow to the North, so it can’t be much more than 9pm… Then look at my watch and see it’s 2245BST.

Not quite the land of the midnight sun but almost.

Took about 3 minutes to undo my handiwork :smiley:
Newsotadata should be back now.


Thanks Andrew. Could you or anyone reading this please give me the URL of the new database?
I’m away from my PC for a few days where I had it saved.

73 Phil


Thank you Martin. I’m on it now.

73 Phil

Many thanks Andy and team it’s racing along now.73 Don.

I guess the database upgrade is not the reason for the issue, but this looks like a good place to report on it: on the lefthand side of the sotamaps screen, the lists of summits of both E7 regions contain duplicated entries for all old summits (the ones making the lists before the recent expansion). Also, selecting any of these duplicated entries in the list or clicking on the corresponding icon in the map area produces “Unkn own summit!” error.

And two little bugs in the newsotadata software:

  • When displaying entries for a particular callsing, the default sublist (entries from the last 12 months) in the default order (Jan-Dec) appears on the screen, but the dropdown menus for the period and the ordering of entries are empty, i.e. not displaying the default values.

  • When one selects a particular summit from the list of summits in a SOTA region, there is no return button to the region page. Using the browser’s back button returns the user to the Bouvet Island page.

And another little one: the third column in the list of individual summits activated by an operator is titled “Contacts”, although something like “Activations” would be more appropriate (in my view, at least).

Hope solving these would not keep you awake till the midnight (sun).

We are aware there is something “different” about E7. It may have been my last update.

With a new DB server and software upgrade and also having to update my home PC (disk,ram, OS) so I can also use the latest DB software and a few other things, I haven’t had a chance to see what is not right.

I’m hoping to blame somebody/anybody other than me but it’s not looking good!

Tell me about it.

If it can help by any means, you can blame me (the messenger).

The repeated summits have the same data apart from points/bonus. They came from a re-evaluation of the summit bands and changing the bonus height. I’ve done this many times for other summits and it has worked. Just needs a time slot for me to find out where the mistake was made. (And to blame someone else!)

Just trying to download logs from newsotadata but can’t as I get the messages that this site is unsafe or file not found. (Safari)
Tried chrome “Your connection is not private.Attackers might be trying to steal your information from downloads.sota.org.uk (for example, passwords, messages or credit cards).
no problem with old sotadata

This is a different issue to what has been happening with our hosting company. I don’t know what the cause of this problem is. This is in Andrew’s domain and it’s 5am local time for him and so it will need to wait till he is up and looking forward to another day of software issues.

You can either wait or use the older database application we have (sotadata.org.uk).

Ask if you want further explanations and I’ll do my best.

No rush -was just looking at my OE contacts for their award and can use the old database - just thought it hadn’t been mentioned before.

I “fixed” that yesterday but neglected to reload the cert into the web server. It’ll be fixed in a few minutes

1 Like

…and fixed now.

1 Like

Thanks again for your efforts Andy. Used it twice now and it’s working perfectly! 73, John

Thanks Andy - working now!

cough Andrew cough

no problem, I shouldn’t have broken it in the first place :slight_smile:

1 Like