GPX files links - how to use?

Hi all
I’m a newbie SOTA convert and was wondering if there is a way to make links to GPX files work? Here’s an example of a GPX file a user posted. I cannot for the life of me get it to load into the GPS. Is it me?

Suggestion: Instead of copying and pasting the text, how about saving the file in the cloud and linking to the file instead?

Thanks for the help!

In reply to KC2NEO:
Hi Sean

The best place for activators to share their routes is to store the GPX files by loading them into the SOTA Mapping Project, which is run by Rob DM1CM. This makes it easy to download GPX files directly on to your computer and or GPS device. No need to bother with a cloud then as we have our own storage facility provided voluntarily and independently by Rob. I just wish more activators would use it… you just need to read the help files, register an account free of charge (donations appreciated by pensioner Rob who puts a lot of time into the SMP).

I was told by one of the German SOTA ops I met recently at Ham Radio in Germany, that he thought some activators prefer to be asked for information, rather than sharing it freely so we can all access it more easily without favour!

73 Phil G4OBK

PS It is also a waste of bandwidth to put GPX files into the reflector. especially when they don’t work!

In reply to KC2NEO:

Sean, I took a look at the link you provided, and it struck me that the major problem with uploading the text there, is that the GPX code is littered with many “” elements. These are HTML/XHTML elements denoting line-breaks in a HTML document, and do not belong in a well-formed GPX document. See, e.g. GPX: the GPS Exchange Format for further information on GPX.

As Phil G4OBK has pointed out, the SOTA Mapping Project’s tracks page exists to accept GPX files from users, and already features over 900 user-defined and -uploaded tracks/routes to SOTA summits worldwide.

Other GPX upload solutions, of course, exist on the web; and those who feel the need to keep their GPX files private or between close friends are welcome to do so…

Best regards, Rob

When I simply deleted these elements from the beginning of the file, the gpx worked for me:

73, Barry N1EU

In reply to N1EU:

Barry, the fact that you were lucky enough to find a device sufficiently tolerant of such errors in the given GPX code (or a haphazardly cut-down version of it) is more a tribute to the authors of the device’s software than to the legitimacy of the GPX code.

Try running the code through the standard GPX code parser, the Xerces XML parser (follow the links at Validating GPX Files): the parser borks at each and every “” it finds in the document; and there are 534 of them.

What happened to work for you in this particular case cannot be guaranteed to work for others: the way to go is to adhere to agreed standards - in this case, the official GPX XML schema: . Try removing all the “” elements in the given GPX file, and you will then find that the parser reports that the GPX code passes inspection. Works for me…


A late PS: many thanks to the kind OM who made a contribution today to the SMP - I tried to contact you privately to express my gratitude, but unfortunately, my email was rejected as spam.