Other SOTA sites: SOTAwatch | SOTA Home | Database | Video | Photos | Shop | Mapping | FAQs | Facebook | Contact SOTA

Database Update for SOTAGoat app?

Is there a “fix” for database updates for the SOTAGoat app? It appears to start downloading a database but then fails. I believe that is tied to SOTAWatch2. I emailed WW1X but have no idea if he will respond.

Derek, WF4I

Dear all

Same here today March 1 on iPad and iPhone both – the file downloads, says “working”, and then SOTAGoat aborts instead of scanning through the associacitions and regions as usual. Still has run well some days ago (but then in February 2020).

Vy 73 de Markus, HB9DIZ

The probable cause is the summitlist.csv file is fractionally different now. When I get a chance I’ll fire up a snapshot of the old database and compare the file with what is generated now.

Could someone try this now and see if it works?

Crashed again

OK, then it’s probably a SOTA Goat issue.

Derek,
If you use the search facility just up to the top right (the magnifying glass icon) and search for sotagoat, you’ll find a long discussion from November 2019 in which Rockwell participated, saying he intended to bring it up to date and release a version that uses the latest links, databases, interfaces etc.
There were over 30 “likes” on his post so I think it’s a safe bet he knows it will be appreciated.

73 Andrew VK1DA/VK2UH

2 Likes

Hello Andy

There is a difference between the old and new summitslist.csv files. There are different number of fields / columns.

I wrote a note about it in December.

It is in the 2nd phase of the posting the information.

73 de

Andrew G4VFL

Whilst I have not seen or used SOTAGoat I see that the date in the first line of the CSV has changed from DD/MM/YYYY to DD/Mmm/YYYY - where Mmm is the shortened month name - perhaps this has broken it (as it has for my SOTA CSV Editor).

(That change has now been reverted)

Stewart G0LGS

I just made the mistake of trying an update in SOTA Goat. It downloaded the file, started doing the update, and then crashed. Unfortunately by this time it had already thrown away the old summit list and I’m left with nothing, and no obvious way of recovering short of restoring the entire iPad from a backup. There might be some 3rd party tools that can do it but they look a lot of faff.

Looking at summitslist.csv before and after, there seem to be quite a few changes, in particular a lot of additional quoting.

For example before:

G/LD-001,England,Lake District,Scafell Pike,978,3209,NY 215072,-3.2117,54.4543,10,3,02/03/2002,31/12/2099,195,20/08/2019,M0HTY,

and after

G/LD-001,England,“Lake District”,“Scafell Pike”,978,3209,“NY 215072”,-3.2116799354553,54.454261779785,10,3,02/03/2002,31/12/2099,195,“2019-08-20 00:00:00”,M0HTY

Nothing here that suitably robust programming could not cope with, but SOTA Goat is clearly expecting something rather specific.

The use of two different date formats in one record is an exciting innovation; possibly not intended though. Much as I like yyyy-mm-dd format, having it in just one column isn’t ideal.

I think the coordinates are now being presented with rather more precision than their accuracy justifies.

The first line of the file is now back as it was. However I’ve always found that line to be a complete pain. Whilst there’s no rigorous spec of what a CSV file should look like, every general purpose tool that I’ve met wants field names on line 1 and the data from line 2 onwards. I have to strip off that first line before importing into MS Access, for example.

Martyn M1MAJ

I have some examples of the old file in filesystem snapshots (though they will age out in a few week’s time). I can easily send you a sample if it would help.

Martyn M1MAJ

Thanks for the offer Martyn. I can run the old database app at home. It was one of the nice things of developing in Visual Studio… start up SQLserver then load the app source into VS and hit F5 and a few seconds later the app output appears in your browser. It spawned a local IIS-express instance on your PC and worked “just like the real server”. Except it didn’t always. :slight_smile:

VS2019 community edition is fairly stunning… I was writing .NET Core C# code on Windows the other day and running the binary on Linux. All for free.

I think you’ve bricked it. Wait for the update. Less frustrating.
Or go back to your old phone that still has the old version… and an even older database probably…
Or try Sue’s parksnpeaks app. Written for VK users primarily, and a focus on parksnpeaks.org website, but still nice app with logging.
73 Andrew VK1DA/VK2UH

Fortunately my phone is still OK, and has a reasonably up to date database.

I mainly use SOTA Goat on the iPad for casual offline browsing of the summit list, but I can live without it.

It’s just rather annoying that having regular backups doesn’t actually help in a case such as this, but that is an Apple problem.

The main purpose of my posting was to warn other users of SOTA Goat not to attempt a database update at the moment.

Martyn

1 Like

Ok I get it. The phone is still working with an almost up to date database (like mine). But the ipad app is broken due to the failed database update. I guess it is feasible to delete then reinstall with the database supplied when it was last published on the app store. But that would be 3 years or more out of date.

Good idea to warn others not to attempt the update.

73 Andrew VK1DA/VK2UH

Martyn has the 1337 HAXOR skills to do this…

The iPad will be trying to get summitslist.csv from sotadata.org.uk and so you need to make sotadata.org.uk resolve to something you own on your network. Then put the iPad/phone on Wifi and do an update. It will find your proxy sotadata and you can then have it use an old summitslist.csv. A bit of faffing but it should let you recover to a usable state.

1 Like

Yes, I’d thought of that! I run my own recursive DNS server at home so I’m actually quite well placed to do it. Alternatively I could divert the IP address. However I don’t have time at the moment.

Plus, it’s not quite that simple. The http URL for summitslist.csv won’t deliver the file - it redirects to https://www.sotadata.org.uk:443/summitslist.csv. I would hope that the app would refuse to go ahead if the SSL certificate check failed. So I would also need to cobble up a CA, get my iPad to add it to its list of trusted roots (which I think would mean making a profile, which might itself need to be signed). Then I could issue a fake certificate for my temporary server.

This is altogether too much faff.

Martyn

Actually come to think of it, that is irrelevant if the app asks for http, because obviously I can deliver the file. Wasn’t thinking straight. However I just don’t know whether the app asks for http or https, and can’t be bothered to find out.

Martyn

I think it will ask for http, the https redirect was only in place for a few weeks before we shut down the server.

That seems to require a new line in the hosts file, right? Provided there is a check in that file before going to the real DNS.