Other SOTA sites: SOTAwatch | SOTA Home | Database | Video | Photos | Shop | Mapping | FAQs | Facebook | Contact SOTA

Csv file help


#1

After all this time I have started to do a CSV file. however I seem to have a
problem. Some dates are coming up red despite the date format being correct.
The only way I can get rid of the problem is if I delete several rows as deleting the errant one just moves it down to the next row. Do I have some sort of bug ?? I am using Excel. Can any one help please.

Graham


#2

In reply to G4JZF:

You dont have a bug, just an undocumented feature.

For some reason in excel, the correct csv format isnt produced every time. It put blank data in a row or column you dont want.

The way to correct it is fairly simple though.

  1. Open the csv file.
  2. Highlight every empty column to the right of the data (Cols I to IV).
  3. Press Cntrl-Minus (or Edit-DElete)(to delete them, they dont actually dissapear)
  4. Highlight every empty row below the data (right down to 65536)
  5. Press Cntrl-Minus to delete these rows.
  6. Save the file
  7. Close it

It should now work.

Hope this helps

Ian


#3

In reply to G7ADF:
As Ian says Excel is naughty in creating extra CSV fields or records but the procedure he describes should get rid of them. Typing even a single character in any cell outside the range of your desired entries and then deleting it will cause Excel to generate extra fields or records. Generally I find it advisable to open any CSV file created by Excel in a good text editor but not notepad, and check or tidy up the records before uploading.

I recently decided to create a chaser record that only included S2S QSOs, so I downloaded from the database my detailed “All” QSO level activator records as a CSV file. I had recorded all my S2S QSOs. Popped this into Excel and swapped the columns around to match the chaser CSV upload format - really just swapping the call sign columns. Saved that and loaded into a text editor in record editing mode, where I tidied it up deleting all non S2S QSOs via a filter, then uploaded. I found had 223 chaser points from S2S QSOs, but the whole process only took about 15-20 minutes and I didn’t have to go through that slow process of entering them one by one.

Getting the hang of using a text editor to handle CSV files is really worth while. For an activator you can always use the previous CSV files you have uploaded as the basis for a new activation. After all the majority of the call signs will be the usual chasers, so simply reorder the records from recent activations. Following that, if the editor will support global changes (i.e. replace all), summit ref, date e.t.c can be quickly applied and its just a quick run down the time column and you’re done.

For a chaser, the CSV file approach will allow one quick upload for many QSOs especially if you have a busy day or even a backlog.

Good text editors for this are those designed for editing program code and there are a number of free programs available.
If hope I have been clear enough but if not I can try again
73
jim g0cqk


#4

In reply to G7ADF:
Ian many thanks for your help, that seems to have done the trick. That may also explain the problems I have had with other spread sheets. I will have to remember to do that in future.

73 Graham G4JZF

PS
spoke too soon, was going great but have problems again despite redoing what you have said again. Tried a new file and that failed after 40 entries.


#5

In reply to G4JZF:
Can any one else help please


#6

In reply to G4JZF:
Have you tried opening the file in notepad? That may give some indication of where the error lies, whether its an extra comma or a space where there shouldnt be one. If its getting to line 40 then its usually line 39 thats the problem.

Ian
G7ADF


#7

In reply to G7ADF:
It was only with the date that was a problem but yesterday it was also happening with the time aswell which is a straight forward four digits.

I will have a play around again but do not have time to do so today with
two grand childrens birthday parties.

Graham G4JZF


#8

In reply to G7ADF:
Ian I have been able to play around before I go and I cannot see any errors in notepad and I have tried WORD aswel. starting from scratch this morning I got as far as line 60 so for some reason it is varying as wel.
off to party now.
73 Graham


#9

In reply to G4JZF:
Graham

I had a similar problem a couple of years ago. It might not be the same as yours - but. The upload must be in date and time order. One mistype of either or entering a row out of order will screw up the process.

Roger G4OWG