Other SOTA sites: SOTAwatch | SOTA Home | Database | Video | Photos | Shop | Mapping | FAQs | Facebook | Contact SOTA

APRS2SOTA Help

I have run into a problem spotting with APRS for which I need help. For the past couple of activations, I have tried to use APRS to spot for my wife and it keeps reverting to my own callsign as I am the one sending the message. I thought at first I was formatting the message incorrectly, but the format seems to be correct as far as I can tell. Here is an example of what I am trying to send (message body only):

W4T/SU-001 14.000 OTHER K1LIZ TEST

Of course while on a summit, I used the correct mode and frequency. But just a short while ago at home I used the above as a test and it shows my callsign (KI4TN) in the spot when it shows up on SOTAwatch. The spot showed the word “TEST” in the comment, but skipped over her callsign.

We were away from SOTA for a while last spring due to a medical situation, but this method worked before as I was able to spot for her using APRS quite often. But it has not worked for me lately.

Has something changed that won’t recognize spotting for another person? Is it possible that the new database is not recognizing her and I need to get her registered?

Any help is appreciated.

Ron, KI4TN :hiking_boot:

The message log here
https://aprs.fi/?c=message&call=KI4TN&limit=50

2019-11-13 16:09:24 CET: KI4TN>SOTA: W4T/SU-001 14.000 OTHER test
2019-11-13 16:09:28 CET: SOTA>KI4TN: Spotted:KI4TN on W4T/SU-001 14.000 OTHER
2019-11-13 16:10:46 CET: SOTA>KI4TN: Spotted:KI4TN on W4T/SU-001 14.000 OTHER
2019-11-13 16:13:56 CET: KI4TN>SOTA: W4T/SU-001 14.000 OTHER K1LIZ test
2019-11-13 16:13:56 CET: SOTA>KI4TN: Dupe: KI4TN on W4T/SU-001 14.000 OTHER
2019-11-13 16:15:26 CET: SOTA>KI4TN: Dupe: KI4TN on W4T/SU-001 14.000 OTHER
2019-11-13 16:16:53 CET: KI4TN>SOTA: W4T/SU-001 14.000 OTHER K1LIZ test
2019-11-13 16:16:53 CET: SOTA>KI4TN: Dupe: KI4TN on W4T/SU-001 14.000 OTHER
2019-11-13 16:17:26 CET: SOTA>KI4TN: Dupe: KI4TN on W4T/SU-001 14.000 OTHER
2019-11-13 16:18:06 CET: SOTA>KI4TN: Dupe: KI4TN on W4T/SU-001 14.000 OTHER
2019-11-13 16:21:04 CET: KI4TN>SOTA: W4T/SU-001 28.000 OTHER K1LIZ test
2019-11-13 16:21:05 CET: SOTA>KI4TN: Spotted:KI4TN on W4T/SU-001 28.000 OTHER

suggests that it worked in principal.
But it looks like the call sign detections failed.
Maybe Steward can help @G0LGS

73 Joe

Hi Ron,
I presume you have read this: APRS2SOTA Spot Server

Specifically the point about the optional feature - “Activating callsign” may be what you need to use, but it’s not exactly clear to me how you insert that.

Never having used this service, so it’s probably best to contact Stewart G0LGS.

But from my reading of the post, I think if space is a terminator what you’re sending looks correct, but as the comment field can have spaces in it validly, perhaps try with some separator characters if you can - comma semi-colon etc. Something like this

W4T/SU-001,14.000 OTHER:K1LIZ:TEST ignore

I wonder if the “activating callsign” call sign also has to be registered with Stewart so that the system recognises it as a call sign?

73 Ed.

Same here Ron, I just tried to post a spot for K1LIZ using the format that I always use. It posted the spot for me instead. I’ve posted spots for others recently, and just edited my last message and sent it via my FT1D.

I guess post something like ‘new op K1LIZ’ in the comment until this gets resolved.

-Josh WU7H

Edit: Here is my APRS log:

2019-11-13 08:08:56 PST: WU7H-7>SOTA: W4T/su-001 14.063 cw K1LIZ test
2019-11-13 08:08:57 PST: SOTA>WU7H-7: Spotted:WU7H on W4T/SU-001 14.063 CW

I have tried everything I know. I used spaces and commas to separate the fields but there was no difference. I even put “Op K1LIZ Test” in the comment field and it skipped over her callsign and spotted “Op Test” in the comment field. I checked and she has an account in SotaWatch (and the new one too) so that must not be the problem.

I tried putting the text “Activating Callsign” followed by her callsign and that only spotted the words “Activating Callsign” in the comment but skipped over her callsign.

Here is something wierd…I did a test spot with W2SE and it spotted for him. It just won’t spot for K1LIZ.

Ron, KI4TN :hiking_boot:

Ahhhh, I think that is the issue. K1LIZ probably needs to be registered for the APRS2SOTA service. That is good to know - I guess I’ve been lucky that the ops I need to spot via APRS are registered with the service.

From the docs:

" Access to the APRS2SOTA Gateway

If you would like to use the APRS2SOTA gateway then contact me via email so that I can add you to the list of authorised users - I will need your Name and Callsign - You will get an email back when I have processed your request."

Hi again Ron,
I think we need the help of @G0LGS now.
Whether your wife has a SOTAWatch ID, is not as relevant as whether her call sign is registered with Stewart for the APRS2SOTA system - which he runs on his server separate from the SOTAWatch system.

What I am thinking is that the logic is recognising the text as being a call sign and is then checking it against the list of allowed call signs on Stewart’s server, finding it is NOT in the list and simply dropping it.

W2SE on the other hand is probably registered for APRS2SOTA and hence a spot about him works.

73 Ed.

There appears to be some sort if issue with the code when trying to spot other callsigns.

It appears that some callsigns are correctly processed and some not.

It will take me time to try to fathom things out.

A multitude of different stations trying differrent order of parameters makes it harder for me to try to understand what is going on and clutters the SPOTS with irrelevant junk !

I think I have found the problem - code updated.

And all the Test Spots Deleted !

3 Likes

Thanks, Stewart, for the fix! You are most appreciated. :hiking_boot:

Ron, KI4TN

1 Like

Thanks mate, can I buy you a pint!?? Much appreciated.

-J