Other SOTA sites: SOTAwatch | SOTA Home | Database | Summits | Photos | Shop | Mapping | Sotlas | FAQs | Contact SOTA

Anytone D-878UVII Plus - APRS SMS

Has anyone managed to successfully send an APRS SMS message from this radio? I have the latest firmware including APRS and Bluetooth updates. I can connect my smartphone via Bluetooth to the radio, and APRSdroid shows it is connected, unfortunately despite trying to send two test messages to APRS2SOTA both failed, I then tried sending the same message directly from the radio and again nothing. I am registered to use APRS2SOTA.

The issue is about the radio and not sending APRS SMS to APRS2SOTA. If you have it working let me know, please.

Yes, it will work and I managed it a few times however I typed in the message on the radio, not APRSdroid.

You send the sms “to” SOTA and I think the summit/freq details go in the message body. Obviously you need to be getting picked up by an igate when the message is sent.

I can’t check any more details as I lost mine up on a mountain…

Have you got position beaconing working ok on the radio? If that’s working then you know you’re transmitting and being received and you’ve set up APRS correctly in the CPS software.

1 Like

Yes, I have done the Firmware update to 2.05 plus the APRS and Bluetooth update. I am getting into MB7USL about 13 miles away and appearing on APRS.fi

I did a test message when I first put APRSdroid on my phone using APRS-IS which was accepted, I’ve turned APRS-IS off on my phone. When I have tried to send the new messages it seems like they are being sent but nothing happens, no error messages or confirmation.

It would be great if I can get it working as my android phone suffers from being on the Sky mobile network which has the worse signal imaginable!

1 Like

Yes, I was able to successfully place a spot on my Anytone. Before that, however, I had typos in my code, and therefore no feedback.

However, you can view your raw data and corresponding error messages on aprs.fi. Here is a screen copy.
73 Chris


1 Like

Yes, it has left a few people baffled as to what had happened for a time my callsign was featured in part of the text that MB7USL was sending out as DX but not showing up on APRS.fi, as you can see it has now been sorted. I might try later on to see if I can get the SMS to work

Surely you have already registered at https://www.sotaspots.co.uk/.
You can check your code by looking at APRS2SOTA on aprs.fi
73 Chris

2 Likes

It looks like the radio (or the digipeater?) was sending a longitude of 18000 degrees. Maybe it hadn’t got a GPS fix or it was sending a fixed location beacon and it was set up wrong.

Like Chris says above, have you registered for APRS2SOTA? If not then anything you send will be ignored.
There is also an APRS2SMS service which you can sign up for and use for testing the, umm, SMS feature on the radio, just be aware that if you send a mobile number over APRS that anyone can see it (use saved numbers to get around this).

1 Like

Been registered to use APRS2SOTA for months now, the big problem is my phone is on Sky Mobile and it struggles for a signal even when at home, too many times it has let me down, when all I get is “Emergency calls Only” and no internet!

Not sure what the 18000 degrees were all about, I did change it but it seems to default to that, as does the APRS frequency will default to 136 MHz, so I have to make sure I go in and change the frequency after an update, I think the thing to remember is it is a Chinese radio, saying that I have heard that several people are feeding back comments to the makers and getting the firmware updated properly before sending ou so things actually work

I didn’t get any confirmation or errors which means it’s not working my end.

OK, so the bad news is, APRS has stopped working, well it works in a fashion, the local WebSDR is picking up the packets, however, the local digipeater iGate is no longer hearing me, I have wasted a great many hours over months on this, so I seriously think its time to do a factory reset and sell. Where I am DMR is pretty much fractured with different networks that it is almost unusable for DMR anyway. I was toying with a factory reset and starting again but its the thought of another 6 months + trying to get it to work

2 Likes