Other SOTA sites: SOTAwatch | SOTA Home | Database | Video | Photos | Shop | Mapping | FAQs | Facebook | Contact SOTA

Android SOTA Spotter App not allowing edits to spots?

Has anyone had issues with editing their own spots? Also when I submit a spot, the spot doesn’t recognize me as the activator (says unknown). I’ve checked and rechecked my login settings, they’re fine. Plus, they must be good if I’m able to submit a spot and have it show up on SOTAWatch.

I’ve tried reaching out to the author via his site, but didn’t get a response. If this is how the app works, that’s fine, but I can’t tell if it’s working as intended or if there’s a bug or if I’m doing something wrong.

Thanks,
Chris

Before we go any further with this app, can you spot yourself via a normal web browser and edit those spots?

EDIT: I just checked with SOTA Spotter 2.1.515 and I can edit and delete spots I placed with the app.

1 Like

I can spot myself via a web browser and can edit that spot, but I cannot delete the spot once created.

The same spot shows up in SOTA Spotter, but again I can’t edit it through the app. The activator name shows up as “Not Recognised”.

Edit: I can submit a spot via the app and edit the same spot via the webpage, but cannot edit or delete the spot via the app. The says I can only edit/delete my own spots. Via either mechanism it fails to recognize me as the activator.

I impersonated you (such are my super-powers!) and was able to edit and then delete the spots you had placed. So I’m fairly sure your account is OK. I have hard logged out all your accumulated login sessions. Try again with a browser alone and see if it works now for editing and deleting.

I still can’t delete spots via my PC web browser (Firefox), but I can create/edit my spots. Spots on the app are still locked and don’t show my name. I can edit and delete spots through the browser (Brave) on my phone.

One way or another I can manage my spots effectively, but it would be nice to know what’s going on with the Android app as that’s my primary interface while in the field.

I think you’ll find that that doesn’t meet the service standards the MT have for our tools, so something needs doing.

Can you use the Contact SOTA link from the top of the reflector pages and send a message to the MT about this. That way an item gets put on the MT list so that we can ensure we don’t forget to fix this.

Hi Chris,

I didn’t get any message from you; there’s probably something wrong with the Contact form on my site, I’ll have to check that out.

As for SOTA Spotter, it uses the API available for third-party apps which, as Andy pointed out, works fine for other accounts. This leads me to suspect that there may be a problem with your account. Unfortunately I cannot help you debug such issues, but perhaps the MT can.

Please keeps us informed here about your progress with this problem.

73,
Bogdan YO3SAW

Try again - your callsign was all lowercase and that may have caused an issue. You may need to log in and out.

That was it! I logged out and logged in via SOTA Spotter with an all caps user ID and it works now. My spots still show up as “Activator not recognised”, but at least I can edit/delete via the app. :slight_smile:

No worries. It seems to be working except for not identifying me as the activator. I’ll still report it to the MT just in case it’s indicative of a problem.

Thanks!

In the past I have had problems caused by a stray trailing space after my callsign. That caused a mismatch between the user id when posted initially and the user id I used when I later logged on to update or delete the alert.

As phone apps typically add spaces after words, trailing spaces are not uncommon. Also initial capitalisation of text can cause problems.

This comment is from just another user, I do not represent the developer or the MT.

No-one represents the developer but himself :slight_smile:

You are correct though about the trailing spaces; SOTA Spotter does a sanitization of the strings before sending them to the server. Or at least it used to. It seems “the developer” has broken that with the latest updates. I’ll take a look at that when I can.

73,
Bogdan YO3SAW

2 Likes

From my end , I saw this thread and did a couple of tests.

I made sure that I was logged in in the app as VE2DDZ in caps, no trailing spaces. I wasn’t able to delete a test spot, there was no response from the app when I pressed the garbage can. I force stopped the app and restarted it. When I pressed the garbage can, I got a confirmation yes or no. When I pressed yes, the app closed and the spot was not deleted. I did this multiple times with the same behaviour each time - confirmation Y/N - press yes - app closes.

But I was able to edit the spot without problems.

Hi Malcolm,

If you haven’t done so already, please submit a crash report when prompted by your Android. That is the most helpful thing you can do in situations like this one. If I get a report, I’ll take a look at it and maybe figure out what went wrong in your case.

73,
Bogdan YO3SAW

Ah, OK. I got the prompt to send the crash report, but it wasn’t clear whether the data went to the developer or just to Google/Android. I will try to reproduce the crash and send on the report

Take care,
Malcolm

Hi Bogdan,

I can’t reproduce the crash now. Everything is working properly in SOTA Spotter for me now, no crashes and I can edit and delete spots without problems.

I’ll watch and if I have any issues in the future, I will send on the reports.

Take care,
Malcolm

1 Like

Whenever an app crashes and you send the crash report, it gets sent to the developer’s Google account. It will then be visible in the developer console and it contains, among other things, the call stack as it was at the moment of the crash, many times this being enough to identify the problem.

1 Like

If this isn’t documented in the FAQ, could an entry be added? Without any error messages or something in the FAQ, I would have never guessed this was the cause. Usernames aren’t normally case sensitive.

Thanks!

This isn’t something that should be documented in the FAQ, it should be something that never happens. So a fix would be better suited :slight_smile:

Yes they are! At least in the Unix/Linux world which is where you are with Android.