Other SOTA sites: SOTAwatch | SOTA Home | Database | Video | Photos | Shop | Mapping | FAQs | Facebook | Contact SOTA

Update to SSO Server

Tomorrow morning Australian time (8 Jul around 2200 UTC) I will be updating the backend SSO servers in turn. Being clustered, this should not result in any outage for anyone, but will likely log you out and log you back in.

There is also a slight change in the theming, so do not be surprised if the login page changes.

2 Likes

Had a few issues with this, but got it working. However, this caused an issue with the SOTA API that backends SOTAWatch3, so I have reverted the change for now. I will revisit with Jon overnight and attempt again maybe tomorrow.

1 Like

After tracing down the issue with the SOTA API, we’re ready to cut this over again, and will start this in the next 30 minutes or so. You shouldn’t see an outage, but you will likely need to re-login.

All done. Any issues, let me know

4 Likes

Thanks, Andrew. Will the SOTA Reflector also switch once to SSO?

Thanks for all this maintenance and development work,
and vy 73 de Markus, HB9DIZ

Eventually.

When logged-in the summit pages are not displayed.
Just

Loading…

https://summits.sota.org.uk/summit/OE/OO-001

They work fine when I logout.

Yep, same here.
Tried Firefox, Chrome and IE8
Also deleted Browser Cache, tried again, i’m loged out, Summit display quickly.
Login again -> Loading (foreever)

Thanks in advance

73,
Mark, HB9DBM

Ok, this is going to be the same issue as before (there was a client side and a server side problem with the API). I guess I missed the summits page. I’ll work on it later tonight after my daughter’s music lesson. In the meantime, log out :slight_smile:

When logged in and I select using the “Search summit” box to find a summit, when its displayed the Stats boxes ie “Total Actns My Actns My Chases” are blank. Doesn’t happen via the Associations search.

Also on SOTAwatch3 in the Reflector section “Pinning” does not work.

Peter

G1FOA

This is the same bug

I’m not sure if it ever did. I’ll take a look

No it never has. Anything that was pinned has slipped down the list.

If you check SOTAwatch2 the SOTA Quarterly news is at the top of the list on SOTAwatch3 its near or at the bottom.

Peter

As suspected, this is due to the client side. Fixed now.

1 Like

Indeed!
Works like a charm now, even when logged in :wink:

Many Thanks for your efforts

73
Mark

This will require a change to the API, so I’ve added an issue for Jon to track

Thanks Andrew no rush.