Other SOTA sites: SOTAwatch | SOTA Home | Database | Video | Photos | Shop | Mapping | FAQs | Facebook | Contact SOTA

SMP new version goes live!

hi rob,

thank you very much for this nice christmas present. it surely looks like you put a lot of effort and time into this major update! but there is one problem i found:

until now, when i upload a track to SMP, i also added an external link on the “summit information page” that leads the user directly to the gps-track. due to your change of the URL’s all my previously entered URL’s are now leading nowhere:


https://www.sotamaps.org/tracks.php?smt=OE/OO-417 (OLD)
https://www.sotamaps.org/tracks/summit/OE/OO-417 (NEW)

not sure if it is possible to fix that easily … or if i have to change the URL’s for all my entries!?

73 and merry christmas de martin, oe5reo

1 Like

Hi Martin,

Yes, this is one of the unfortunate consequences of URLs changing, or changing in form, as applications are updated over time.

I don’t see any easy way to make the necessary changes to the URLs to your tracks - except, possibly to contact Jon G4ZFZ to ask him if there’s a way to make a global change in the data.

In any case, Jon will have to change the URLs pointing to the mapping for each summit in the SOTA site - I’ve already alerted Andrew VK3ARR to this issue.

Sorry I can’t be of more help on this,

Frohe Weihnachten noch!
Rob

2 Likes

Hello this is Gerald F6HBI,
As i wanted to upload a track i must login,
but it is impossible for me, idem to reset the password,
the email never comes!
Any help is welcome.
73 and thanks for the job.
Gerald

Hi Gerald,

You are now using the tracks page in the new version of sotamaps. In order to upload a track, it is necessary to login to sotamaps itself: click on the “Login” button in the upper right-hand corner of the tracks page (or in any of the new sotamaps pages). You must then use the same login details which you use in the SOTAdata site - the old sotamaps login is now no longer valid.

Once you have logged in, you may access the upload area of the tracks page. I’ve just tested this - it’s all working properly.

Cheers, Rob

1 Like

Is it possible to disable the animations on the drop down boxes and the chosen summit box?

Ummm - which animations? which drop-down boxes?

Your own advice would seem a sensible way to help us to move forward here…

I truly appreciate all the hard work you guys do! The resources you’ve made available to SOTA users are worth a fortune.

I seem to be unable to log in to the sota maps page. Instead, I’m getting an error message “kc init failed” and the maps don’t load up.

I’m confused about the SSO password and login? The Database utilizes a “User Name” but other pages like mapping and sotawatch utilize “Call Sign”. In the past my “User Name” was not an exact match to my “Call Sign” - is this part of my problem (if it’s now a SSO then which one is the correct one to use?) However, in all cases I had always tried to use the same passwords.

I’m sure there is a series of steps I need to take but I’ve tried many different combinations without success. At this point I can log in to other pages, but I cannot log in to the maps page. Normally I’d submit this via the “Contact” menu but maybe others will face similar issues so I decided to post it here, hopefully that’s ok.

Merry Christmas all!

73 de Keith KR7RK

This happens occasionally as we integrate these things. Try refreshing the page you’re on with F5 or Ctrl+F5 and try again.

You (and others) often mention “pages”, but what you’re actually talking about are different WEBSITES, which are created and maintained by different teams, and which reside on different machines in different countries.

It might help to think of these websites as different buildings on the same street, with each of these buildings having several rooms - the rooms being the pages. So, the sotamaps site (building) has pages (rooms) called “main”, “range”, “tracks”, etc, each reached by the sotamaps menu which acts as a corridor between the rooms.

Sotawatch has its’ own pages (rooms) called “alerts”, “spots”, etc., but is a completely separate website (building) to sotamaps. And so on…

HTH,
Rob

1 Like

You’re right - this is a source of confusion, and a short guide should be written to explain how to login to the various sites. Perhaps Andrew @VK3ARR could provide us with one…

It is the sotadata username and password. Please don’t go creating new accounts

(Although it is possible, your existing activations and chases from your existing account will not be tied together if you register a new username).

Within SSO, there is the ability to specify your Callsign and Association.

As per everything from the internet involving email, I’d suggest checking your SPAM folder.

The only drop down boxes are these which animate a drop down dialog box . Can it be disabled so the dialog box just appears.

ddbox

The chosen summit box starts by displaying summit xx-001 then scrolls down to the summit selected when you click on a summit on the map. Can it be disabled so it goes straight to what you clicked.

chbox

I will have a look in the morning at the logs to ensure a email has been sent. I’d go and look now but I have a simple rule… If I have been drinking (and I have since early as it’s Christmas Day), I don’t log in and access the admin facilities of the database because it’s easy to do something unintended when the demon drink is running wild through my veins.

1 Like

No, this is on the SSO side, not the db mailer side

See, that’s why I don’t touch the admin pages when I’ve been at the sauce!

As an aside the user name for this user contains chars outwith ASCII 0x1f-0x7f, will that be a problem Andrew?

1 Like

It should be fine - UTF-8 is the default dataset.

Still no luck :frowning: Tried the F5 and Ctrl-F5 and a few other things.

I’m able to log in to the Main SOTA site using my Callsign and password. However, my Database User Name is not the same as my callsign, and to log in to that I need to use that non-callsign User ID.

I cannot log in to the main SOTA website with that non-callsign User ID; if I try that it tells me “Sorry !! We cannot find a user with such information”. On the other hand, I cannot log in to the Database website with my callsign; if I try it tells me “Invalid User Name or Password”.

And on the mapping site, I’m not able to see an option to either log in or log out, and it does not appear to be dependent on whether I have first logged in to any of the other websites or not.

Sorry to be that guy who has to be a PITA on this! But I use the maps site pretty much daily, making plans and uploading tracks etc, so I’m lost without it! I know, I should have just made the original user id’s all equal to my callsign, but when they were all separate and I was a SOTA newbie I didn’t realize it might cause problems later.

BTW I’m using Chrome on a Windows 10 laptop currently. I have other machines that I can try but they won’t be accessible to me for a few more days.

Thanks and 73,
Keith KR7RK

More info…this same error message comes up (“KC init failed”) when I try to log in under either Google Chrome or Microsoft Edge. I was able to load the maps page under Edge (not my normal browser), and it showed the login button. Tried to log in using my Database Username and pw, and it said invalid id or password. Then tried to log in using just my callsign and pw, and then I get the dreaded KC init failed error and no longer see a login button.

KR7RK

OK my apologies for all the bandwidth!

I believe I have fixed my issue. Cleared cookies and was able to find a combo that worked. I still think I have an issue in the SSO system due to callsign versus Username being different, but at least I am in the maps now.

Thanks and 73,
Keith KR7RK