Other SOTA sites: SOTAwatch | SOTA Home | Database | Summits | Video | Photos | Shop | Mapping | FAQs | Facebook | Contact SOTA

recurring invalid summits message

I was browsing the “NL” summits listing and clicking various summit names pick out a future activation. Every summit I tried flashed a quick (less than 1 second) “invalid summit” warning before showing the summit details. Some are major peaks with many activations, so I suspect this is just a programming bug rather than a legitimate message. But, I also wonder if this might mask a few summits that have actually been declared invalid. Of course, I might be missing something :slight_smile: Does anyone have advice about this?
Thanks,
Rich AE1RL

1 Like

By “NL” summits, do you mean PA = The Netherlands?

W1/NL I guess. But it’s the same for all summits. It’s how the display gets updated.

Right, W1/NL.

Any hints on what browser you are using? It’s likely that either the response from the API server is taking a while to process, either due to slow internet or a slow CPU.

I am seeing the same message very briefly.
Using Safari on an iMac
73
Neil

I use Chrome on a fast PC, and get the message when using a 5G connection.
I can live with the message as long as I know it’s OK to ignore it. But the warning does evoke a big “huh?” from me when it pops up.
Rich AE1RL

I’ve tried reproducing this on recent FF and Chrome, and I can’t even see a flicker. Looking at the code, absolutely nothing should be displayed before a valid response is received.

What version of Chrome are you using?

OK, so I looked at this again and I think I can see a potential race condition, but only when accessing a summit via the region list - going to a summit directly would not show the invalid summit message. I’ve pushed a quick change and hopefully that fixes it.

4 Likes

Nice work Andrew. That fixed it! I opened a bunch of summits and none displayed the warning.
73,
Rich

2 Likes