Problem Uploading Logs both CSV and Manual

When I tried to upload a CSV for my most recent activation I got this error.

Error uploading your data: SQLSTATE[HY000]: General error: 20018 The INSERT statement conflicted with the FOREIGN KEY constraint “FK_Activations_Users”. The conflict occurred in database “sotadata_db”, table “dbo.Users”, column ‘UserID’. [20018] (severity 16) [INSERT INTO Activations(UserID, OwnCallsign, SummitID, ActivationDate, Points, BonusPoints, UploadID) VALUES (-3, ‘KG6BXW’, 59265, ‘04/Jul/2020 00:00’, 0, 0, 3957)]

When I tried to enter the data manualy I go this error.
An error occurred while uploading your activation: [object Object]

I checked the reflector to see if others had this problem and I found that it came from having already uploaded the log for that activation site. But when I go into my profile or the summit page I don’t see anything saying that I activated the summit or ever uploaded a log. Could someone tell me what I’m missing here? Thanks a lot and sorry if this is a silly question this is my first time trying to upload a log file for SOTA.

Ah, impressive, you’ve managed to create a username on SSO that’s longer than the column size for username on the database - even after we doubled the size of that table :slight_smile:

I’ll fix this up a bit later when I have access to my set of scripts.


Thanks a lot! I was going nuts thinking I made some silly mistake.

OK, this should be resolved now. You may need to log out and back in.

Cool it’s working now! Thanks a bunch!