Other SOTA sites: SOTAwatch | SOTA Home | Database | Video | Photos | Shop | Mapping | FAQs | Facebook | Contact SOTA

New version of SOTAData enters extended Beta stage

A few days after I saw this thread on the Reflector, I solved the puzzle and got into the Beta database portal. I was motivated by the fact that I use the SOTA database a lot. I do many activator logs with numerous contacts, as well as plenty of S2S contacts, and I spend considerable time doing logs.

I type most of my logs into the database manually. Therefore I care about the features provided, more than those who upload their logs as CSV files.

I’ve submitted two large, real activator logs via the new portal, and they’ve been accepted without any major issues. These were both hand-typed into the fields provided and then submitted. I’m delighted that this interface works so well at this stage!

Most of you are far above me in your understanding of how this database works, but I do have a clear perspective as a frequent user. I realize that we have a Beta version, that many of the points I see may be temporary, and that changes are perhaps intended. Some of what I see may not be what others see, because of differences between our platforms. Here’s what I’ve noted about the Beta Version since I logged on:

  1. The summit cannot usually be selected by simply typing in the parts of the summit reference. Sometimes the Association will come up if I type a letter or letter, but not always. The last three digits always require scrolling down and selecting the number.

It would be nice to just type in the summit information, instead of going through three awkward selections, since we usually know this.

  1. When I’m using the current Operational interface, as well as other software, my computer does auto-fill for many fields. This is mostly a time-saver. So far I’ve seen no auto-fill for the fields in the Beta version.

  2. Each QSO that is typed requires mouse-clicking on the button “Add QSO” for it to be added to the log. Hitting the “ENTER” key does nothing. In the Operational version, hitting “ENTER” completes the entry and is much faster than using the mouse. This is relatively important.

  3. If I skip a contact entry, then discover my omission before submitting my log, I can still type it in at the end of the list with either interface.

In the Operational interface, the added entry is automatically inserted into the list in QSO time order, before submission of the log.

In the Beta version, the added entry remains at the bottom of the list.

However, once submitted, the added QSO ends up in correct time order in the database list, regardless of which interface is used.

  1. The spacing between lines in the Beta version is very wide, so that only 10-12 QSO’s are visible. This is about half what I see in the operational version. This means I have to scroll among the lines much more as I check my entrees. On a big activator log, like the 57 QSO log I did today, this is a bit cumbersome. It would be nice to be able to adjust some of these parameters. The look and feel is very different from an Excel spreadsheet, which most of us are familiar with.

  2. There is very little color in what we see. It’s very gray. A little color is used to great advantage at some of the key transactions, such as entering QSO data, and at log submission. Color is a powerful tool in spreadsheet-type data display, and more color could be used for the main features. Our brains key in on color, we process it very fast, and good websites and pages use color to advantage.

  3. The operation of the Beta version is incredibly smooth. I’ve not seen a single glitch or hang-up since I first logged on. I’ve used most of the menu functions, accessed various logs, downloaded logs, entered S2S contacts, and looked at logs of others, and it all flows perfectly. It seems as fast as the Operational version, even when downloading huge piles of logs, which I have done.

In contrast, the Operational database often kicks me out, for no apparent reason, and sometimes requires me to do multiple log-ins to complete even a single activator log. It also kicks me out when I do S2S logs, which are fairly short, but then I must re-type all the information - it isn’t in the buffer like the activator logs. Some days are worse than others, but the Operational interface either times-out or otherwise glitches, and I see the screen of junk that tells me I have to log in again.

Up to now I’ve assumed it was because of my older system, my router, my WiFi, my typing errors, hitting two keys, etc., and who knows what that caused me to be un-logged.

The new interface - so far - is smooth as silk, absolutely delightful by comparison! I haven’t tried a long delay yet, but my comparison experience is like night and day!

  1. The pages are simple and uncluttered, and they are very clean.

  2. However, the font I see on the Beta version is not very easy to read - it’s not jet-black, the letters don’t have sharp edges on my large, sharp monitor, it looks more gray, and it needs improvement.

The Operational Database is much easier to read, even with the denser fields and closer lines, and it’s all about the font and the type. I wish I could pinpoint the problem better, but legibility is VERY important.

  1. The menus on the new version work fine - but I prefer drop-down menus, or some combination - perhaps we could use redundant choices. The menus are really small, and they would be better with color.

  2. The complete logs are easier to read in the Operational version. They use boxes, black fonts, etc.

  3. The formats we use for the dates D/M/Y when we enter our log data are reversed from the format Y/M/D used to display our stored logs.

  4. The complete stored logs don’t show the time period or dates covered by the log, at the top of the log, where it matters. Every log displayed should tell what period it covers. We should not have to scroll down through our huge collections of logs to see what period each one covers.

  5. The Beta version of the manual S2S entry page has major improvements over the Operational Version.

While the fields are essentially the same, when entering more than one S2S contact, if I click “Add Another”, the Operational Version wipes all the fields clean and I have to retype ALL the information for EVERY field. The Beta Version keeps ALL the information in the fields, so all I need to do is update the key details of the QSO.

In particular, the information for MY summit ref is still there, so I don’t have to go through the cumbersome summit-ref selection process for each S2S log entry!!

This is a HUGE improvement, very helpful! Of course not clearing the fields can cause errors - if a field that needs to be be changed is not edited, the log may contain an error. I still like not having to re-type every field!

  1. The headings on the log spreadsheets appear in a very tiny font - and they stay at the top of all the columns, so we can’t see them while looking down the logs - at least the headings should be larger and bold, maybe even displayed in color. If all the columns were colored, we would soon learn what each column contained, never mind the headings! More color - more legibility - less fatigue.

  2. The Analysis features for the activator and chaser logs are very cool! I was surprised to see these options. They work smoothly and reasonably quickly. While the displayed results are HUGE, it all runs just fine through my old hardware!

  3. When submitting most logs, or downloading, a large blue rotating circular display appears to show that something is happening. This is much better than an hourglass or whatever.

However, when I SUBMIT an S2S log, I see nothing to indicate progress. There is no rotating circle, nothing. The log is uploaded, but there’s no progress indicator visible.

  1. I checked to see if my S2S logs processed through the Beta version are correctly updating my chaser logs, scores, etc., and so far I see no problems. The interface seems to be doing just what it should, going into the SOTA Database.

I may seem critical of a few points here, but overall I’m just amazed and delighted that this new product is running so efficiently. I know these great results represent untold labor and mental challenge over countless hours.

Please accept my comments in the positive spirit of suggesting a few useful improvements that will have a huge positive effect for the thousands of users who will soon use these tools to enter and display their SOTA logs.

This is a long post, but I really believe that the reason you gave us the riddle to solve, was to select a few motivated early users, and not to have too many people posting useless comments.

I’m not sure if you want feedback - but since you posted a fun riddle I could solve, at over 70 years old, you got it. This Beta version is an amazing piece of work - and with a few significant tweaks it could be so cool!

I’m running this on a Dell Pentium desktop machine made in 2003, with 2G of RAM, using Windows XP, Google Chrome, over a WiFi router and a cable modem. It runs SO MUCH BETTER than the Operational version that kicks me out! I think the data transactions to the database are faster with the Beta version, but I have no way to be sure.

When I solved the riddle, I wasn’t sure if I really wanted to see where it would lead. So far, so good!

Thanks and 73,



Took me a little while to track this down: 60m is being reported by the API, and the 60m column was present on the page too, but I’d left the 60m column out of some CSS, and the browser decided the best way to display that would be to collapse the column from view.

Your iPad has failed to download the icon font that’s specified.

Perhaps so, but where did the additional text come from, overlaying the standard menus? Ie. the words “account circle, library books, terrain, cloud upload”

The normal menu titles are displayed in a different font underneath those texts. I’m theorising this has come out of a javascript library function that is not being suppressed. But just a guess.

Andrew VK1DA/VK2UH

That’s the actual character names within the font library. Without the font, it’s displaying that in whatever your default font is.

Wow, I worked on a SAP enterprise portal still running in IE6 compatibility mode and I thought I’d seen every weird message possible!

Reported as it seemed slightly odd. Ipad users are used to odd things happening though!

73 Andrew VK1DA/VK2UH

I can reproduce this on Firefox and not on Chrome. However, the old version of sotadata has this same behaviour too. I suspect this is actually browser related, and not related to the new/old versions. A few hours of googling hasn’t helped me resolve this issue. It’s definitely related to the ‘/’ in the dropdown, and I suspect it’s Firefox’s Find As You Type feature that’s somehow getting in the way (possibly https://bugzilla.mozilla.org/show_bug.cgi?id=254592).

Otherwise, there is also a timeout on the time taken between key presses that can trip up some people. The easiest option may be just to revert to ‘001 - Summit blah’ instead of ‘AA/BB-001 Summit blah’

When you say Auto-fill, which fields are you talking about? I keep Mode/Band the same, but it doesn’t seem to make sense to auto-fill time, callsign or comment, as these are pretty certain to change each time.

When I push the next version this will be fixed.

This should now be, ahem, sorted. (Once I push a new version)

I’ll play around a little bit with the style sheet. The general vibe is most people entering 57 QSOs do it via CSV though :slight_smile:

Any suggestions on where to liven it up?

This is probably due to the fact the old version has a 5 or 10 minute time out. If you’re doing 57 QSO activation entries, I’m not surprised it takes longer than 5 or 10 minutes :slight_smile: You should get at least 10 hours before being reprompted to log in.

It’s probably a darker background on the older version. The font color is black. It’s a standard web font, designed for readability across screens big and small.

There have been many arguments about the menus. We’ve settled on the current version as causing the least amount of quasi-religious warfare - including about the menus being too large, too animated, not animated enough, too small, etc etc.

Do you mean the SOTA Complete logs, or complete logs of activator/chaser/etc? I’m trying to avoid putting in too many boxes as they can look very cluttered on smaller screens.

Actually, when you enter date data now you have a date-picker, not a free form text, and the CSV file accepts Y-M-D format properly now (thanks Martyn!). The idea is to eliminate options where Americans with their crazy date format get confused by the rest of the world and what they do :wink:

I’m a bit confused by this - there is a drop down box at the top that you specify what date range you want?

I can make the headings bigger - but what would you want the colours to be? (Bearing in mind you will start the aforementioned religious wars if they colours are not quite right in someone’s mind :slight_smile: )

This should be fixed in a later version.


If you have enabled 2FA for SSO login, is there an easy way to update sso.sota.org.uk for when you need to replace the auth app on your phone (or change phones)?

Go to https://sso.sota.org.uk/auth/realms/SOTA/account and play with the Authenticator tab on the left. If you’ve lost your old phone already, I’ll need to reset the account.

Well damn, that was easy! I feel like I missed a post with these instructions already.
I am good to go, Thanks Andrew

73 de N6JFD

At risk of committing thread necromancy, I will be utilising the beta nature of Newsotadata to take it offline around 4pm AEST (0600 UTC) for various manipulations required to support upcoming backend changes. Should be down for around 1 hour.

1 Like

starting now due lack of activity on the server.

…and back. Total outage was about 50 minutes.


Thanks for the heads up.
Any remarkable functions/features to have a looks at?

No, it was a combination of patching and prepping the server for CI/CD. Makes my life easier in the long run :slight_smile:



I apologize if this is the wrong window to be lined up at. Tried to post elsewhere but it did not stick AFAICT.

When bringing up ASSOCIATIONS page and selecting FILTER, the VK3 filter also brings up VK9.

While this is undoubtedly a feature, I do not need it and wonder if the filter could be more selective and only bring up VK3?


Out of curiosity and more out of procrastination to avoid getting outside to do yard work, I poked around a bit. VK1 and VK2 also pull up multiple associations. It looks like it may be filtering based on the association manager’s callsign as well. VK2’s AM is VK1DA, VK8 is VK2AXL, VK9 is VK3WAM. Hopefully that helps some in troubleshooting.

73, pat - KI4SVM

I think you are right, it is sorting on the Association manager, and it was Wayne who surveyed and presumably still “manages” the vk9 associations.

VK1DA/VK2UH (only vk2)

While we tend to base all our decisions on the “What does Ron need?” principle, the filter here allows searching by any column, not just by association code. Try searching for DL and you’ll get Newfoundland too. If we changed it, then searching for Newfoundland or Victoria would not return VO1 or VK3.

Not everyone knows the association code and “Why is my country not listed” is a common enough query and the answer is just as frequently that it is listed that allowing a wide search makes more sense.

It’s not like the search filter didn’t return VK3 for you

This topic was automatically closed after reaching the maximum limit of 100 replies.