This last week I was able to spend some time in Sequoia National Forest and activate a few peaks in between fishing and typical camping activities. I was actually able to activate two previously unactivated peaks, which I might write a summary on later.

My question to the SOTA community is about the MTR5b. On my last activation, I sent out a spot, and pressed “RIT” and “M1” to send my preprogrammed initial SOTA CQ message to hit the RBN; however, the unit somehow went into a kind of beacon mode.

Because I didn’t have the manual and I didn’t know how to stop the beacon, I powered off the unit, and attempted to turn it back on. When I flipped the power switch back to the “on” position, the screen remained blank but the backlight came on. I then disconnected the battery and reconnected it which resulted in the same effect.

I tried to drain the capacitor memory by leaving the unit in the “on” position with the battery unplugged for a few minutes on the summit, but the unit would not display text or allow any kind of manipulation, so I completed my activation with my HT on VHF.

On the drive back to the camp, I left the MTR in the “on” position, and battery unplugged. About two hours later, I then turned off the MTR, plugged in the battery, and turned on the device and things seemed to be back to normal. Of note, the only other difference than a longer time delay was an increase in temperature from about 45 degrees to around 60 degrees F.

Just a FYI I also launched an email out to LNR to ask if powering down the MTR during a memory recall function is something that shouldn’t be done or if this is a problem. I re-read the manual as well and didn’t see anything in there that referenced a hard reset.

Thanks in advance for any info on this! It was kind of a challenge to work through the problem on the summit, but thankfully I always pack a HT as a backup & got some locals and a mobile station that were up early and monitoring.

-David, KM3A

Hi David,

I have the MTR5b and experienced some anomalies after I had owned it for a couple of months. I emailed LNR and heard back same day (on a Sunday) that my glitch was likely due to the internal battery running down, and was advised to remove the battery if I didn’t need the clock. I removed the battery (didn’t need the clock function) and the problem was resolved. Shortly after that I noted that a revised manual came out with notes on the potential battery issue.

While you could give this a try if you’re in a hurry, it might be best to wait on a response from LNR before you open it up. My experience with their inquiry turnaround was quite good.


Paul - N1ZF

1 Like

Thanks for the reply! Seems your recommendation solved the issue. I use my GPS for UTC, so I don’t really need the radio to keep time. I appreciate the response! I was worried my MTR needed repairs, but things seem to be working fine now after the battery removal.

I don’t have an MTR radio, but it seems to me that when one has a radio with a feature, and one must remove the battery to disable that feature in order to prevent a bigger problem, that’s an issue. Is there a firmware fix, either available or promised?

I got a reply from LNR that said to replace the battery. I don’t see a way to upgrade the firmware, and they didn’t mention anything about it.

I think I’ll just operate it without the internal battery. It’ll just reset the settings and frequencies each time I power down, but I don’t really have any unique settings to store, and changing a frequency is pretty easy. Plus those watch style batteries are expensive, so operating without one will save a few bucks :slight_smile: I’ll admit though, I was pretty bummed on the summit and worried that the unit somehow got damaged. I am relieved now to know that the solution was pretty easy.