Other SOTA sites: SOTAwatch | SOTA Home | Database | Summits | Video | Photos | Shop | Mapping | Sotlas | FAQs | Facebook | Contact SOTA

Mobilink TNC - Do you have one?

I bought a Mobilink TNC end of last year, I also had the cable for using it with an Alinco DJ-175 HH, unfortunately, I have not been able to get it working, the error message on APRSdroid says BT socket error and to turn off any other connected devices, my phone is an Android, I tried the app for i-phone and this doesn’t work properly. I did contact the makers months ago but they said it will be down to getting the mobilink TNC app working correctly! I would love to get at least one of my APRS equipment being able to send SMS messages

I have the TNC3, originally got it for use with my FT-60r and iPhone. Silly question do you have the latest firmware installed on it? Have you tried connecting via the usb cable to your computer?

1 Like

It has the latest firmware only gets connected to charge up now as there is nothing for it to connect to on my PC

Hello Paul,
I may be able to help you. I have had a Mobilinkd since 2016 and used it successfully with 3 radios, an FT817, HTX-202 and Yaesu FT65, and various Android phones with APRSDroid.
Your note mentioned problems with APRSdroid, and then later mentioned Mobilinkd TNC and implied that this second app, TNC, was not working. Since TNC is used to set all the operating parameters of the physical modem I can see why you were not able to get APRSDroid and your radio working together.
My Mobilinkd device stopped working several months ago. When I connected TNC by Bluetooth, the TNC app would not work properly, the main symptom being “Firmware unknown”, and a distinct lack of controls as described by the manual. I solved this (long story made short) by opening the case, physically disconnecting the battery for 30 seconds, and reconnecting. Everything now appears to be working as described in the manual.
So, maybe you would like to try the battery disconnect, then see if you can establish connection with the TNC app. If this is successful, the last task is to configure APRSDroid to control your radio.

Good Luck!

1 Like

By way of an update, I remembered I still have my old android phone, so I connected that up last night I need to go through the settings as I am not convinced that isn’t using APTS-IS, hopefully this will fix the blue tooth conflict error as my smartwstch isn’t connected to this phone

It is something to do with the settings as I’m getting the Bluetooth socket error again, could you post some screenshots of your settings, it would be a big help in seeing what is wrong, thanks! I’m off out now to activate my local SOTA summit,

1 Like

Sorry I got caught up in moving, is the socket error with the TNC app or the APRS app? I have seen where on my iPhone I can get an error one one or the other depending on which one was opened first. If I remember correctly the actual mobilink app is only used for setup and then you can close it and then open the aprs app.

2 Likes

I have a Mobilinkd TNC3 and have used it successfully for APRS spotting with a couple of different HTs using an iPhone and the aprs.fi app.
73,
Mike K6STR

1 Like

I need to look through the Mobilink settings to ensure they are correct, then those for APRSdroid, I thought it was a BT conflict between my smart watch and my phone, but the old phone is not connected to the smartwatch which suggests it is either a problem with the settings or failing that the supplied cable from Mobilink doesn’t work, the radio is an Alinco DJ175, I’m not tied to this radio just thought I would give it some life as an APRS transceiver, I also have an Icom ID51E, Yaesu FT-818 and an Anytone D878UVII Plus.I will post some screenshots later on today, it is probably something very simple! The error message is BT socket error.1 Thanks

Ok, I have now tried it again, and I have noticed that when I click connect on the Mobilink app the red light comes on the TNC, however, the radio does not key up. This suggests to me that the cable that was supplied is the wrong one! I did ask at the time of purchase.

So my options now are:

  1. Buy a cable from Mobilink for FT-818, the only issue here is it isn’t clear which cable, if you have one let me know, please?

  2. See if Technofix UK, can supply a correct cable, they do a range of PTT cables so if they can supply the cable which is for an Alinco DJ175E

No doubt someone is going to say why not make one yourself, in the case of the Yaesu plug it is tiny and fiddly and I have never done phono/jack cables before

1 Like

What is this “buy a cable” that you speak of kemosabe? Just make it yourself.

1 Like

I hate messing around with small cables! Have you seen how small a Yaesu plug for the 817/818 is?

Yes. I used to make up FT817 cables and sell them on eBay so I have hand soldered hundreds of mini DIN plugs. And countless Kenwood fullsized 13pin DIN plugs. Enough profit to pay for a TS570DGE :wink:

You are slowly bringing me round to the idea look at the prices which don’t include shipping! TNC Cables | Mobilinkd

So you got the app part of the issue sorted out?

As for jumping from DJ radio (that probably uses the Kenwood HT cable) to an FT818 don’t know what to say. As for knowing Yaesu connectors the MiniDIN-6 TNC Cable is the one to go for.

Most of the Mobilinkd cables are single brand cables. They are also wired to correctly to use the ptt.

1 Like

I have asked several people who sell data leads and none of them does the on for the Alinco, I kept this radio purely for APRS with Mobilink, and even bought a new bigger battery for it. I think the trouble with it is it is a double plug which is fairly small!

It’s a standard size. But why are you making life so hard for yourself. Just buy an Alinco accessory with the correct cable and use that to make what you need.

e.g. this → Headset for Alinco DJ-175 / 193 / 195 / 196 / 446 / 493 / 496 / 560 / 580 / 593 | eBay for £12.

2 Likes

It’s still small, and doesn’t look like you can take it apart, so how do I know that the accessory in the link you provided is wired up correctly for a TNC? There are no diagrams for wiring up a headphone plug for the radio. I found out the hard way last week with a 6M power amp that what the diagram implies is totally different from how you actually attach PTT wires. As far as the TNC goes I am going to have to get the Yaesu 817 cable and hope that works with my 818 instead, defeats the object of being able to spot quickly though.

You don’t take it apart. You buy it because it’s a cable with the correct plug fitted. You cut the crud off the ends and throw them in the recycling and use the cable to connect to the TNC. Saving you finding a nice 3.5/2.5mm combi plug with the right spacing and having to fit it. The TNC is a 3.5 TRRS. The DJ-175 manual shows how to wire it up. 10 min job. 30min if you stop and have a brew during assembly.

1 Like