Other SOTA sites: SOTAwatch | SOTA Home | Database | Video | Photos | Shop | Mapping | FAQs | Facebook | Contact SOTA

SOTA CSV Editor


#41

A further update is now available.

Stewart G0LGS


#42

I have just got around to trying my SOTA CSV Editor under Wine on Ubuntu 14.04 on my Dual core (32 bit) Laptop. A search found some information on setting up Native ODBC in Wine at http://wiki.winehq.org/NativeOdbc which was enough to allow me to get ODBC working to allow my program to work and create the .mdb (although it is much slower creating it that in Native Windows.

Stewart G0LGS


#43

Very good news Stewart!

Thank you for spending some time to test it.

I’ll try it soon, and if I get it to work on my small portable machine, it will be adopted for the coming activations :wink:


#44

Hi Stewart,
I have reinstalled sotacsv Editor, on my new desktop system. Very good product.

I sometimes write up my log as a plain text file in csv format. Having done it a number of times I don’t need to consult the help about the format or field order. In those cases I like to use your editor to import the csv and export an ADIF file, as I use your field abbreviations to populate the name and rst fields.

But to import my CSV files into SOTA CSV Editor I find I need to put the times in hh:mm format instead of the hhmm format accepted by sotadata. The hhmm format (ie. no separator colon) causes alarm and error messages! If you were at all inclined to accept hhmm format it would be a simplication in my csv to adif conversions for those files. Others may find that useful too.

73
Andrew
vk1da


#45

The format ‘HHMM’ is not one I’ve seen before in any SOTA file - all the ones I’ve used from SOTA web sites use the ‘HH:MM’ format.

Stewart G0LGS


#46

The code is quite clever and can accept a myriad of different formats for the time. Not code I wrote but code that is in the framework libraries that is. I think it will accept 2015/27/4 or 2015-4-27 or 27th April 2015 and many more formats for the date. As long as what you enter is not ambiguous, the code will be able to figure out a time or date. Best is to enter in the format on the info page.


#47

Hi Stewart

If you are entering an activation you can leave the colon out of the time but from memory if you are entering a S2S contact it expects the colon to be included in the time. Not sure why there is a difference but I’m sure that’s what I’ve found.

Nice program by the way.

73

John VK6NU


#48

Hi Stewart,
yes the downloaded file from SOTAdata is always in the HH:MM format, true. I was referring to a CSV file I had created using other means (via excel, or notepad++) and in those files I had taken the minimalist (lazy) approach of using the HHMM format.
73
Andrew vk1da


#49

It has been reported to me that my SOTA CSV Editor does not work properly when you have date/time settings in Windows that are different to the UK DD/MM/YYYY format (specifically the US MM/DD/YYYY format).

Stewart G0LGS


#50

Hopefully today’s update to V1.3.0.0 (available in the usual location) will address the problems with using non-UK date formats.

Stewart G0LGS


#51

EDIT2:
on import to DB I get all blank fields and “ignored” at the end of each line- any suggestions? This is my first time using this method. I tried .tsv as well and have verified all entries are correct and complete. Tried FF and IE w same result- all blank and notes column all report “ignored”. I also tried using the editor in the extras section to upload the file but get the following error:
“JSON parse error” SyntaxError: JSON.parse: unexpected end of data at line 1 column 1 of the JSON data"

EDIT:
internal updater did not work but grabbed the latest v1.3 and it works thanks very much!

I cannot update the date on an existing log. Sounds like you might already be aware of this but how can I work around the date format issue?
Thx
C


#52

It seems that you are doing something with uploading to the Mapping Site - the CSV created from my program works fine on the SOTA Database upload.

I have hardly looked at the SMP site, but having just tried I too get the JSON error on uploading one of my CSV’s, but if I export the CSV to ADIF and upload that things work much better (but SMP site doesn’t like 10GHz/3cm band).

In my SOTA CSV Editor to edit an existing entry just double-click anywhere on the line in the log window and you should be able to edit it.

Stewart G0LGS


#53

I first tried to upload to the DB site. It does not work for me as I explained. The 2nd thing I tried was to convert a log to SOTA friendly CSV etc. not uploading to any mapping site. The extras on the mapping site are just that- extras. This was suggested to me previously when log upload was not working properly:


You actually contributed to that same thread.
I just tried export to .adi then into the converter in the extras section. Same result- an empty log on uploading to DB.
Anyway, I get a blank log when uploading the csv from the CSV editor to the SOTA DB.
I am just going to do it manually again. I simply have no luck with these tools that are supposed to make log submission quicker.
Thanks
C


#54

This is what it looks like:

thx
C


#55

The parser is saying “Ignored” because the line in question is not for an activation.

You can mix chaser and activation records in the same file, when you upload that file as an activation all the chaser records are reported as “Ignored” and when you upload the same file as a chaser log all the activations are “ignored”.

In the case shown, there is no entry in the file for your own summit. Just check you are trying to upload an Activation(s). if these are chaser QSOs you need to select “Import Chaser/S2S/SQL TSV/CSV”


#56

Clifford,

(Thanks for the Clarification Andy).

If you were using a V1.0.0.9 or earlier of my program for Activator logs you may have failed to understand that the new version does not work quite the same.

V1.2.0.0 and later only save files in the (v2) CSV format that permits both Chaser and Activator entries in the same log.

In these later versions of my program you should enter your own reference (if any) in the ‘My Ref’ (or My Summit) entry field and only enter the other stations reference (if any) in the ‘Summit’ entry field.

Stewart


#57

I did not use the ref field at all thx:

v2,KK6QMS,26/05/2015,01:35,144MHz,FM,KR6RG,W6/SC-337,kr6rg 5/11 635pm intl border
v2,KK6QMS,26/05/2015,01:38,144MHz,FM,KB6WWI,W6/SC-337,kb6wwi 638pm
v2,KK6QMS,26/05/2015,01:39,144MHz,FM,K6VGP,W6/SC-337,k6vgp 639pm 5/5
v2,KK6QMS,26/05/2015,01:40,144MHz,FM,KK6FUT,W6/SC-337,kk6fut Ben mobile 5/13
v2,KK6QMS,26/05/2015,01:42,144MHz,FM,KD6RCM,W6/SC-337,kd6rcm Todd w simi 5/13
v2,KK6QMS,26/05/2015,02:01,144MHz,FM,N6TZ,W6/SC-337,n6tz 5/13 HAL camarillo 701pm
v2,KK6QMS,26/05/2015,02:21,144MHz,FM,KC6UIH,W6/SC-337,kc6uih Mark thousand oaks -0 721pm (ft100d)
v2,KK6QMS,26/05/2015,02:51,144MHz,FM,KD6DSH,W6/SC-337,kd6dsh mike sbarbara 751pm
v2,KK6QMS,26/05/2015,02:56,144MHz,FM,W6KGB,W6/SC-337,w6kgb Matt 756pm


#58

That looks as if you have created a Chaser Log (with a number of different operators on the same summit).

I suspect that is meant to be an activator log, but you have entered the summit details into the wrong entry box in the editor - edit each entry and put the W6/SC-337 reference in the ‘My Ref’ box and remove it from the Summit box.

This will give a CSV like:

v2,KK6QMS,W6/SC-337,26/05/2015,01:35,144MHz,FM,KR6RG,,kr6rg 5/11 635pm intl border
v2,KK6QMS,W6/SC-337,26/05/2015,01:38,144MHz,FM,KB6WWI,,kb6wwi 638pm
v2,KK6QMS,W6/SC-337,26/05/2015,01:39,144MHz,FM,K6VGP,,k6vgp 639pm 5/5
v2,KK6QMS,W6/SC-337,26/05/2015,01:40,144MHz,FM,KK6FUT,,kk6fut Ben mobile 5/13
v2,KK6QMS,W6/SC-337,26/05/2015,01:42,144MHz,FM,KD6RCM,,kd6rcm Todd w simi 5/13
v2,KK6QMS,W6/SC-337,26/05/2015,02:01,144MHz,FM,N6TZ,,n6tz 5/13 HAL camarillo 701pm
v2,KK6QMS,W6/SC-337,26/05/2015,02:21,144MHz,FM,KC6UIH,,kc6uih Mark thousand oaks -0 721pm (ft100d)
v2,KK6QMS,W6/SC-337,26/05/2015,02:51,144MHz,FM,KD6DSH,,kd6dsh mike sbarbara 751pm
v2,KK6QMS,W6/SC-337,26/05/2015,02:56,144MHz,FM,W6KGB,,w6kgb Matt 756pm

Which should work when uploaded using the ‘Import Activator CSV/TSV’ option.

Stewart G0LGS


#59

Neil 2M0NCM figured it out after I sent some screenshots and logs. Thanks again Neil.

1- I had no idea there were different logs for activator and chaser- I just figured you have a basic .csv log and choose the appropriate upload when you send it to the DB.

2- I assumed a log was a log and the SOTA CSV Editor just made a log you would later upload either as an activator or chaser. The SOTA CSV Editor has (to me) an obtuse way of specifying whether it is to be an activator log or a chaser log. If you fill in “summit” it will be a chaser log, if you fill in “my ref” (huh?) then it will be an activator log.

I tested it after clearing the summit fields and filling in the “my ref” fields and it worked.
At least now I know how to utilize it in the future.
thx
C


Error on .csv import
#60

There used to be 2 different CSV formats, one for Chaser and one for Activators, which mean the Editor needed to know which log format you wanted and to be able to load/save both versions and it originally used one entry box for either purpose.

However since V2 of the CSV/TSV format was devised to cope with S2S awards there is now NO real difference to the CSV format for Chaser / Activator - the only difference is where the summit information goes on each line.

This meant that the newer version of the program had to have two entry boxes.

Yesterdays updated version attempts to make it clearer which of the two entry boxes should contain which information (the labels and Tool-Tip text have been changed).

If anyone has any other idea how I can make it clearer which box to use then I welcome suggestions, as I do for any thing else that people feel might improve the overall look/feel or increase ‘user workflow’ (as someone suggested by email Yesterday), but I will not promise to implement everyone’s ideas.

Stewart G0LGS