Other SOTA sites: SOTAwatch | SOTA Home | Database | Video | Photos | Shop | Mapping | FAQs | Facebook | Contact SOTA

MX-P50A HF amplifier


#1

Hi there

My MX-P50A arrived this morning. UK shipping appears to mean DHL from China. Fist impressions are that it is quite a heavy lump (good in some ways). No instructions and operation not entirely obvious (the band select “switch” is a pot for example). External build quality is adequate (think MFJ but not Yaesu). I will review with photos and measurements on my business Facebook page.

73 and have a great Christmas

Richard
G3CWI


#2

In reply to G3CWI:

It does not appear to cover the 30m band.

What is the function of the “Band” switch marked | and O ?

73,
Walt (G3NYY)

PS : Tks for the SOTA QSO yesterday from G/SP-013. You were 10 dB over S9 here!
(400w ?) hi hi!


#3

In reply to G3NYY:

Pretty sure the filters will be simple low pass designs so I would expect 20/17m position to suffice on 30m (not optimal of course) and the 40m position to work on 60m. The switch toggles between manual and automatic band switch (for the FT817).

FET is an MRF186.
http://datasheet.seekic.com/PdfFile/MRF/MRF186.pdf
…an interesting choice. Should be totally indestructible.

I was using a little extra power yesterday - modified CB amp.

73

Richard
G3CWI


#4

In reply to G3CWI:

Hi Richard,

I’d be interested to hear about your modified CB amp, since i’m in the process of modifying one for use on the summits.

I’ve aquired a RM KL203, but have modified it for operation on the lower HF bands down to 80m, by changing the input transformer to type 73 material. I’ve added a HF Packer switchable Low pass filter module to the output stage.

It seems to work and have had some good reports. The only unknown at this stage is the IMD, so i’ll make sure I don’t overdrive it.

73

Robert
G0PEB


#5

In reply to G0PEB:

Hi Robert

I also have an RM KL203 - will be comparing this with the MX-P50A (and the HF Packer) over on the SOTAbeams Facebook page.

Best wishes for Christmas and the New Year

Richard
G3CWI


#6

In reply to G3CWI:

Hi Richard,

Will look forward to reading your reviews.

Merry Christmas and HNY.

73

Robert
G0PEB


#7

May be of interest.

73

Richard
G3CWI


#8

I’ve just bought one of these amps but I’m having a problem powering it from my LifePo4 battery (Hobby King 4,200 mah, all cells functioning as they should). I’ve tried it on two different fully charged batteries and it just lights up and then goes off as if something is tripping. It works fine on my linear power supply and on a SLAB. Does anyone have any suggestions as to why?

Thanks

John MM0VEG


#9

Assuming your batteries are 4 cell, then max fully charged will be somewhere close to 14.4 /14.5 volts
The P50 is rated at 15v max input, but i would think that individual units may vary in sensitivity.
P50 input range is 11 to 15V with 13.8 as optimum
I suspect your problem is over voltage.
Your linear is most likely close to 13.8V and the slab 12V ?
Suggest you check the output voltage of all 3 and see what the difference is.
If it’s working fine on the lower voltages than that would suggest over volts on the input from the LiFePo4
is tripping the amp.

Hope this helps
73
Neil